[Top] [All Lists]

Re: [PATCH v4 5/7] MIPS: KVM: Rename files to remove the prefix "kvm_" a

To: Deng-Cheng Zhu <>, David Daney <>
Subject: Re: [PATCH v4 5/7] MIPS: KVM: Rename files to remove the prefix "kvm_" and "kvm_mips_"
From: Paolo Bonzini <>
Date: Fri, 27 Jun 2014 16:27:52 +0200
In-reply-to: <>
List-archive: <>
List-help: <>
List-id: linux-mips <>
List-owner: <>
List-post: <>
List-software: Ecartis version 1.0.0
List-subscribe: <>
List-unsubscribe: <>
Original-recipient: rfc822;
References: <> <> <> <> <> <>
User-agent: Mozilla/5.0 (X11; Linux x86_64; rv:24.0) Gecko/20100101 Thunderbird/24.6.0
Il 27/06/2014 00:44, Deng-Cheng Zhu ha scritto:

x86 calls these things irq.c and irq.h, perhaps that would be a little

There's also include/linux/irq.h

Yes, I know.

I simply wanted to let you know that if arch/mips/kvm/interrupt.h and
include/linux/interrupt.h are consufing, then arch/x86/kvm/irq.h and
include/linux/irq.h the same -- not even a little better.

And one of them is included as <linux/irq.h>, the other as "irq.h". So there's no possibility of confusion.

"kvm_mips_" seems totally useless as a prefix. I'm ambivalent with respect to removing the "kvm_" prefix; I'll apply the patch.


<Prev in Thread] Current Thread [Next in Thread>