[Top] [All Lists]

Re: [PATCH v4 5/7] MIPS: KVM: Rename files to remove the prefix "kvm_" a

To: James Hogan <>
Subject: Re: [PATCH v4 5/7] MIPS: KVM: Rename files to remove the prefix "kvm_" and "kvm_mips_"
From: David Daney <>
Date: Thu, 26 Jun 2014 17:32:22 -0700
Cc: Deng-Cheng Zhu <>, Paolo Bonzini <>, Gleb Natapov <>,, Sanjay Lal <>, Ralf Baechle <>, Linux MIPS Mailing List <>
Dkim-signature: v=1; a=rsa-sha256; c=relaxed/relaxed;; s=20120113; h=message-id:date:from:user-agent:mime-version:to:cc:subject :references:in-reply-to:content-type:content-transfer-encoding; bh=XLf0OwuF97/uSCr2YqIaYUgLEPJgz+FDSfJBrNa751M=; b=RZU6xtcz3m2mTWCOuHFAPsCJlI5sSwsgojYaD+x3EBzwosP6jxqvMkJPiX2zJ3NZ+R fQx2LIsZCspCa/39ewuRSrnC1/O44CJuJC1vb5nKS+8LE7b+lGnO3cd50lcAJD981Igq ZdqDWXwXF9paJEn36M+wgotzu5Zx+FqeTMKD8uGxs0VfwZOfokF1ZBC/VN7LSry4mD3R fM54XW7IS/npa0oIYsDM1fERb1CGNe4RgaGKUpquzAKSI23w7HtGZoHjqXCa/TINSeIG er7dVhfkQ/EdJqRMhq8o8FfPN2emRNRPVIzwY/XNQlUuVhS6TglGvH029iIQoayHIkQE Imog==
In-reply-to: <>
List-archive: <>
List-help: <>
List-id: linux-mips <>
List-owner: <>
List-post: <>
List-software: Ecartis version 1.0.0
List-subscribe: <>
List-unsubscribe: <>
Original-recipient: rfc822;
References: <> <> <> <> <> <>
User-agent: Mozilla/5.0 (X11; Linux x86_64; rv:17.0) Gecko/20130625 Thunderbird/17.0.7
On 06/26/2014 04:21 PM, James Hogan wrote:
On 26 June 2014 22:55, David Daney <> wrote:
There is precedence in x86 for some of the names though.

But really why churn up the code in the first place?  the kvm_mips
prefix does tell us exactly what we are dealing with.

That's why people created the arch/mips/kvm directory, isn't it?

No.  Segregating things into directories keeps code related to one
functional area together.

File names are different.  They should carry as much meaning as possible.

For examples of this look at some of these directories:


It is not bad to have a filename prefix related to the function of the

Hi David,

More importantly if you look in arch/*/kvm/, very few of the files
have kvm in their names except for mips.

Personally I find the filenames Deng-Cheng is suggesting must less
cumbersome to type. Most of the files start with kvm_mips_ at the
moment, which is completely redundant.

As for churn, renaming the files hardly produces much churn compared
to cleaning up coding style issues like some of the other patches, but
I still think even they are worth doing.

I have expressed my opinion.  I don't want to spend any more time on it.

Let the maintainers decide what they want to do.

David Daney

<Prev in Thread] Current Thread [Next in Thread>