[Top] [All Lists]

Re: [PATCH v4 5/7] MIPS: KVM: Rename files to remove the prefix "kvm_" a

To: David Daney <>
Subject: Re: [PATCH v4 5/7] MIPS: KVM: Rename files to remove the prefix "kvm_" and "kvm_mips_"
From: James Hogan <>
Date: Fri, 27 Jun 2014 00:21:49 +0100
Cc: Deng-Cheng Zhu <>, Paolo Bonzini <>, Gleb Natapov <>,, Sanjay Lal <>, Ralf Baechle <>, Linux MIPS Mailing List <>, James Hogan <>
In-reply-to: <>
List-archive: <>
List-help: <>
List-id: linux-mips <>
List-owner: <>
List-post: <>
List-software: Ecartis version 1.0.0
List-subscribe: <>
List-unsubscribe: <>
Original-recipient: rfc822;
References: <> <> <> <> <>
On 26 June 2014 22:55, David Daney <> wrote:
>>> There is precedence in x86 for some of the names though.
>>> But really why churn up the code in the first place?  the kvm_mips
>>> prefix does tell us exactly what we are dealing with.
>> That's why people created the arch/mips/kvm directory, isn't it?
> No.  Segregating things into directories keeps code related to one
> functional area together.
> File names are different.  They should carry as much meaning as possible.
> For examples of this look at some of these directories:
> drivers/net/ethernet/intel/ixgb
> drivers/i2c/busses
> It is not bad to have a filename prefix related to the function of the
> files.

Hi David,

More importantly if you look in arch/*/kvm/, very few of the files
have kvm in their names except for mips.

Personally I find the filenames Deng-Cheng is suggesting must less
cumbersome to type. Most of the files start with kvm_mips_ at the
moment, which is completely redundant.

As for churn, renaming the files hardly produces much churn compared
to cleaning up coding style issues like some of the other patches, but
I still think even they are worth doing.


<Prev in Thread] Current Thread [Next in Thread>