[Top] [All Lists]

Re: mips; boot fail after merge 3.9+

Subject: Re: mips; boot fail after merge 3.9+
From: Jonas Gorski <>
Date: Thu, 2 May 2013 10:32:27 +0200
Cc: "" <>,, "" <>, "" <>
In-reply-to: <20522420.158691367384219315.JavaMail.weblogic@epml17>
List-archive: <>
List-help: <>
List-id: linux-mips <>
List-owner: <>
List-post: <>
List-software: Ecartis version 1.0.0
List-subscribe: <>
List-unsubscribe: <>
Original-recipient: rfc822;
References: <20522420.158691367384219315.JavaMail.weblogic@epml17>
On Wed, May 1, 2013 at 6:57 AM, EUNBONG SONG <> wrote:
> Hello.
> After merge cavium board boots fail, boot log messages are as follows.
> I enabled initcall_debug for debugging.

I can confirm that MIPS does not seem to finish to boot after using
the generic idle loop, I have the same problem on a different platform
(bcm63xx), and bisecting showed the same commit.


> I found this issue after cdbedc61c8d0122ad682815936f0d11df1fe5f57.
> And i found something strange. I ran the git show for this commit.
> As below "select GENERIC_IDLE_LOOP" is added for CONFIG_MIPS.
> but the latest arch/mips/Kconfig file has not this one. I have tried to find 
> when this is gone. but i can't find.
> Is there any problem with this?

No, after all architectures were converted to use the generic idle
loop the config symbol was removed, so it's now always on. The problem
is rather that the generic idle loop does not seem to work on MIPS.
Unfortunately due to limited knowledge in this area I can't really
tell which part broke it.


<Prev in Thread] Current Thread [Next in Thread>