[Top] [All Lists]

CPU hang on cpu_wait in CPU_74K

Subject: CPU hang on cpu_wait in CPU_74K
From: Rafał Miłecki <>
Date: Fri, 1 Feb 2013 23:44:08 +0100
Cc: Hauke Mehrtens <>
Dkim-signature: v=1; a=rsa-sha256; c=relaxed/relaxed;; s=20120113; h=mime-version:x-received:date:message-id:subject:from:to:cc :content-type:content-transfer-encoding; bh=dCNw1WBN6CHA2gU8BCYoksczFuUaBU25m2G/GICzwQI=; b=fbpV/BpJT8J4UYdUWZxNPA5/325nBk+oO9/R1/ii/qI/z3rsz0GdXJG1Uxgq1QQZOX ELwOOt+zRXAkfM3f+8RIeBttKpXg1S9pDP1ccsRwUo1Tbps8Zud4r9bKt04BUU00OkDd HNzNFp6IQ9ANtJmsUYALScGL0xp780DUyrvAhgRErhNPERiJzMvUYs6i+CiZjX48QZse 4pujIfEX4vG8+VDcv4IJ5IJkFiuIzgWa1GC6uyoHcrRFfRBKI1+NgtKbYZ08pm8dUZEU aT+o+ErYLyZVu+POQ0aB5lhPg2WIuGTnP6rchJFhLGqflCAKbCj8bPshMBfDxU4/xIsA NLlg==
List-archive: <>
List-help: <>
List-id: linux-mips <>
List-owner: <>
List-post: <>
List-software: Ecartis version 1.0.0
List-subscribe: <>
List-unsubscribe: <>
Hello again ;)

I'm hacking a BCM4706 based board which uses a 74K CPU. The problem is
that wait_cpu (see cpu-probe.c) hangs my machine (is happens as soon
as the first [um]sleep is called).

The hang is related to the cpu-probe.c and:
> cpu_wait = r4k_wait;
> if ((c->processor_id & 0xff) >= PRID_REV_ENCODE_332(2, 1, 0))
>       cpu_wait = r4k_wait_irqoff;

If I remove that lines completely [um]sleep doesn't hang machine
anymore. I'm not sure if removing that code is a proper solution. I'm
not sure what is the
> c->processor_id & 0xff
on my machine, but I've tried forcing both:
> cpu_wait = r4k_wait;
> cpu_wait = r4k_wait_irqoff;
and both are causing hangs.

If I recall correctly, Hauke was checking Broadcom's code and they're
using the same solution: removing that lines completely.

Do you have any idea how this could be solved?


<Prev in Thread] Current Thread [Next in Thread>