[Top] [All Lists]

Re: booting linux-3.3 or linux 3.4 on an SGI O2?

Subject: Re: booting linux-3.3 or linux 3.4 on an SGI O2?
From: Joshua Kinard <>
Date: Sat, 23 Jun 2012 15:30:39 -0400
In-reply-to: <>
List-archive: <>
List-help: <>
List-id: linux-mips <>
List-owner: <>
List-post: <>
List-software: Ecartis version 1.0.0
List-subscribe: <>
List-unsubscribe: <>
References: <> <>
User-agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:13.0) Gecko/20120614 Thunderbird/13.0.1
On 06/05/2012 3:08 PM, David Daney wrote:
> On 06/05/2012 12:00 PM, Jim Faulkner wrote:
>> Hi all, I haven't been able to boot any kernels after linux 3.2 on my
>> SGI O2.  I've tried linux-3.3.5 and linux-3.4.0, but neither would boot.
>> Unfortunately I don't have further information such as a kernel panic,
>> since I don't get any video output after the kernel is loaded.  I've
>> attached my linux-3.4 .config.  Anybody know what patches I might need
>> to get the latest kernels booting on this system?
> I have had problems as well.
> Someone should configure a serial console and early printk to see if they
> can see what is happening.

Early printk on O2 systems probably has the same issues as on IP22/IP28
where it's overwriting PROM memory somewhere.  The system will hang very
early in the bootmem allocator if you kludge early printk to work on these

System Maintenance Menu

1) Start System
2) Install System Software
3) Run Diagnostics
4) Recover System
5) Enter Command Monitor

Option? 5
Command Monitor.  Type "exit" to return to the menu.
> $ba
Setting $netaddr to (from server )
Obtaining  from server
5305628+400900 entry: 0x80009920
Initializing cgroup subsys cpu
Linux version 3.4.4-mipsgit-20120623 (root@helcaraxe) (gcc version 4.6.2
(Gentoo 4.6.2 p1.3, pie-0.5.0) ) #2 Sat Jun 23 15:20:20 EDT 2012
PROMLIB: ARC firmware Version 1 Revision 10
CRIME id a rev 1 at 0x0000000014000000
CRIME MC: bank 0 base 0x0000000000000000 size 128MiB
CRIME MC: bank 1 base 0x0000000008000000 size 128MiB
CRIME MC: bank 2 base 0x0000000050000000 size 128MiB
CRIME MC: bank 3 base 0x0000000058000000 size 128MiB
bootconsole [early0] enabled
CPU revision is: 00002733 (RM7000)
FPU revision is: 00002720
Checking for the multiply/shift bug... no.
Checking for the daddiu bug... no.
Determined physical RAM map:
 memory: 0000000010000000 @ 0000000000000000 (usable)
 memory: 0000000010000000 @ 0000000050000000 (usable)
Zone PFN ranges:
  Normal   0x00000000 -> 0x00060000
Movable zone start PFN for each node
Early memory PFN ranges
    0: 0x00000000 -> 0x00010000
    0: 0x00050000 -> 0x00060000

I tried chasing this down once, years ago, and it was triggered by a pointer
to a function in a struct suddenly becoming NULL.  That was back in 2.6.15
(or .14?), so no idea if the same issue is causing it.  Most likely.

Joshua Kinard
4096R/D25D95E3 2011-03-28

"The past tempts us, the present confuses us, the future frightens us.  And
our lives slip away, moment by moment, lost in that vast, terrible in-between."

--Emperor Turhan, Centauri Republic

<Prev in Thread] Current Thread [Next in Thread>