[Top] [All Lists]

Re: Using NFS with HIGHMEM support

To: "Dennis.Yxun" <>
Subject: Re: Using NFS with HIGHMEM support
From: Ans_linu <>
Date: Wed, 29 Feb 2012 15:13:25 +0530
Authentication-results:; spf=pass ( domain of designates as permitted sender); dkim=pass
Cc: Jacky Lam <>,
Dkim-signature: v=1; a=rsa-sha256; c=relaxed/relaxed;; s=gamma; h=mime-version:sender:in-reply-to:references:date :x-google-sender-auth:message-id:subject:from:to:cc:content-type; bh=b7Av3XqmpTnXBW0jNo+I1tZU8Ydc0DFx3gidTW1RhTc=; b=dSm3X5P2U+jy01hfAHeOpfw1RFWM65tOpV18YoTioZJvhdH58seMmb5trk0UVwFJca i62szniLmlnauFUOKo78nR56HmZwdF8fl11+5BG+q+K14EuXa/uxoTqMf8PzhTGwHSGg NHkN54OJr1575JPRwuC9+/N81yhxtB0CuzMRo=
In-reply-to: <>
References: <> <>
Hi ,
I have faced similar issues before.
Not sure this will help. But please take a look at.

On Mon, Feb 27, 2012 at 3:34 PM, Dennis.Yxun <> wrote:
 I'm encountered pretty much the same problem here
 I'm tracing with current 3.3-rc4 branch(from ralf's tree)
 If I put rootfs at nand flash + highmem enabled, then execute problem may give
illegal instruction error, bus error, try it again may run success.
 but if I don't enable highmem, then problem is gone.
 any hints? thanks


On Mon, Nov 28, 2011 at 4:37 PM, Jacky Lam <> wrote:

   I am using mips-linux-3.0.4 with HIGHMEM enabled. Everything is working fine, but I find something strange that when I execute a statically-linked binary through NFS mounted directory. It will gives me an illegal instruction error or  SIGSEGV. If I run it again, the binary can run without problem. I have to reboot or drop all the vm cache in order to reproduce the error again.

  Also, if I run the binary in harddisk or dynamically link the binary, no problem will be found.

   Any suggestion to debug this problem? Thanks.


<Prev in Thread] Current Thread [Next in Thread>