[Top] [All Lists]

Re: Using NFS with HIGHMEM support

To: Jacky Lam <>
Subject: Re: Using NFS with HIGHMEM support
From: "Dennis.Yxun" <>
Date: Mon, 27 Feb 2012 18:04:29 +0800
Authentication-results:; spf=pass ( domain of designates as permitted sender); dkim=pass
Dkim-signature: v=1; a=rsa-sha256; c=relaxed/relaxed;; s=gamma; h=mime-version:in-reply-to:references:date:message-id:subject:from:to :cc:content-type; bh=mXoxL2GBjrcHD6mD5sMylTWgDDiYPkffcbLVEKgPfCE=; b=vJL2wTG7taoA+mP2RhRYkpDWe5EREAAZqCO8MIzBP2DnJI8qgcZ7UJmjb++bQRw9+D E157lYSd+BvlQcNxJ/6ES9DJ22/O2h9SXFUIsa5RWA9IrEDYNqwkGYdlnLbT1w704M4y bJbmxIE+Q56PJzD+Eb/bP2cb4FWLScNsxSD58=
In-reply-to: <>
References: <>
 I'm encountered pretty much the same problem here
 I'm tracing with current 3.3-rc4 branch(from ralf's tree)
 If I put rootfs at nand flash + highmem enabled, then execute problem may give
illegal instruction error, bus error, try it again may run success.
 but if I don't enable highmem, then problem is gone.
 any hints? thanks


On Mon, Nov 28, 2011 at 4:37 PM, Jacky Lam <> wrote:

   I am using mips-linux-3.0.4 with HIGHMEM enabled. Everything is working fine, but I find something strange that when I execute a statically-linked binary through NFS mounted directory. It will gives me an illegal instruction error or  SIGSEGV. If I run it again, the binary can run without problem. I have to reboot or drop all the vm cache in order to reproduce the error again.

  Also, if I run the binary in harddisk or dynamically link the binary, no problem will be found.

   Any suggestion to debug this problem? Thanks.


<Prev in Thread] Current Thread [Next in Thread>