[Top] [All Lists]

Using NFS with HIGHMEM support

Subject: Using NFS with HIGHMEM support
From: Jacky Lam <>
Date: Mon, 28 Nov 2011 16:37:18 +0800
Dkim-signature: v=1; a=rsa-sha256; c=relaxed/relaxed;; s=gamma; h=message-id:date:from:user-agent:mime-version:to:subject :content-type:content-transfer-encoding; bh=SzZO0W/+mSaqlADCsI0D5eAtD/ndTckFGO+kadPcuJ0=; b=u9RsydtuEM0U5VdUPY1LNSsA0MHx3pEYCJi5Q8hExtEFJcxVOWxrhSFVrZie3Aq2Ef MRANuLP2oqkcKMHhg3S6oSwHgfYkwEnZNOgubrsQrDf/O6NbWxM3fUrMkanJrIzB7/pn LQRbfG+t4uUeZmOUcPW2ppniz7cPG37OCtzAg=
User-agent: Mozilla/5.0 (Windows NT 5.1; rv:8.0) Gecko/20111105 Thunderbird/8.0

I am using mips-linux-3.0.4 with HIGHMEM enabled. Everything is working fine, but I find something strange that when I execute a statically-linked binary through NFS mounted directory. It will gives me an illegal instruction error or SIGSEGV. If I run it again, the binary can run without problem. I have to reboot or drop all the vm cache in order to reproduce the error again.

Also, if I run the binary in harddisk or dynamically link the binary, no problem will be found.

    Any suggestion to debug this problem? Thanks.


<Prev in Thread] Current Thread [Next in Thread>
  • Using NFS with HIGHMEM support, Jacky Lam <=