[Top] [All Lists]

Re: [PATCH] ath9k: rename ath9k_platform.h to ath_platform.h

To: Kalle Valo <>
Subject: Re: [PATCH] ath9k: rename ath9k_platform.h to ath_platform.h
From: Sangwook Lee <>
Date: Tue, 22 Nov 2011 09:17:38 +0000
In-reply-to: <>
References: <> <> <> <>
Hi Kalle

On 17 November 2011 19:06, Kalle Valo <> wrote:
Hi Sangwook,

On 11/16/2011 01:34 PM, Sangwook Lee wrote:

> On 15 November 2011 16:37, Kalle Valo <
> <>> wrote:
>     Hi Sangwook,
>     On 11/15/2011 01:23 PM, Sangwook Lee wrote:
>     > The patch series proposes to rename ath9k_platform.h to
>     "ath_platform.h
>     > This header file handles platform data used only for ath9k,
>     > but it can used by ath6k as well. We can take "wl12xx.h" as
>     > as a example. Please let us change this file name so that
>     > other Atheors WLANs use this file for their own platform data
>     ath9k and ath6kl are very different devices, I'm not sure if sharing a
>     platfrom struct between the two is really a good idea. Most likely there
>     is very little the two drivers can share. What are your plans here?
> As you know, if ath6kl is not SDIO powered (in most of cases, including
> mine)
> we need to use platform struct in order to control reset/power line,
> because ath6k is designed for mobile and embedded devices.

We have been actually planning to do the same, but it's still on our
todo list. If you can do this it would be awesome.

I did it but because my hw2.0 AR6003 has another problem, I couldn't go further.
Simply I copied the same method from wl12xx wlan driver.
(Maybe you might have know it)

You can run "grep" the following definition, which is used by Panda board.

It will increase small bits in WLAN driver but discard platform data from init section  at booting time. 

Also we need to provide some clock configuration from the board file and
I'm sure there will be more in the future. But let's start with the
power control.

> so I found out that there is already header file for ath9k's platform
> struct. How about using the one header file instead of
> "include/linux/ath9k_platform.h"
> , and "include/linux/ath6k_platform.h" ?
>     I myself was thinking that we would have include/linux/ath6kl.h
>     dedicated just for ath6kl. That would makes things simpler.
> But since I don't know much about ath9k, if you want to make the
> separate header file for ath6kl's own struct, It would be fine as well.

Yeah, I really would like to use separate file for ath6kl.


<Prev in Thread] Current Thread [Next in Thread>