[Top] [All Lists]

Re: [patch] hugetlb: remove dummy definitions of HPAGE_MASK and HPAGE_SI

To: David Daney <>
Subject: Re: [patch] hugetlb: remove dummy definitions of HPAGE_MASK and HPAGE_SIZE
From: Linus Torvalds <>
Date: Mon, 21 Nov 2011 16:55:13 -0800
Cc: David Daney <>, David Rientjes <>, Andrew Morton <>, "" <>, "" <>, "" <>, David Daney <>, "" <>, Robin Holt <>
Dkim-signature: v=1; a=rsa-sha256; c=relaxed/relaxed;; s=gamma; h=mime-version:sender:in-reply-to:references:from:date :x-google-sender-auth:message-id:subject:to:cc:content-type; bh=UR59dpucMtx33HLIdlDQGxv38z8nmrF82d7082OOOXY=; b=q0GjJTyiDOXuIkldwUlhmgGYFwIC5bn06QuG+khH3e2fyDtlefnMw3qUMOJ51WzEkJ XMFFIjgQokioLkZ4TuYLkqXF5uC/zzS3I5Ul6U7HwzZDXGhOBYq7gCELhfrikAVpthD4 qmTZFixFYqLC5KfFFqZasY4BApImVJO4w6O8Q=
In-reply-to: <>
References: <> <> <> <> <> <> <> <>
On Mon, Nov 21, 2011 at 4:48 PM, David Daney <> wrote:
> Really Linus, did you read the other half of the message you quoted?

Sorry no. It was just an automatic reaction along the lines of "oh
christ, is this argument still going on"?

I'm ok with magic gcc function attributes, although I still don't see
why you need that symbol so badly.

Quite frankly, some MIPS-only patch is *not* important-enough to worry
about this. I'd rather have the simpler "that symbol doesn't exist,
and MIPS just needs an #ifdef".

I realize that we *used* to have code that did that

   if (something_that_evaluates_to_zero) {
       .. use HPAGE_MASK ..

but considering that we don't have that any more and people are happy,
I'm not all that convinced that we need to try to re-introduce it.


<Prev in Thread] Current Thread [Next in Thread>