[Top] [All Lists]

Re: [patch] hugetlb: remove dummy definitions of HPAGE_MASK and HPAGE_SI

To: David Rientjes <>, Andrew Morton <>, Linus Torvalds <>
Subject: Re: [patch] hugetlb: remove dummy definitions of HPAGE_MASK and HPAGE_SIZE
From: David Daney <>
Date: Mon, 21 Nov 2011 14:23:36 -0800
Cc:,,, David Daney <>,, Robin Holt <>
Dkim-signature: v=1; a=rsa-sha256; c=relaxed/relaxed;; s=gamma; h=message-id:date:from:user-agent:mime-version:to:cc:subject :references:in-reply-to:content-type:content-transfer-encoding; bh=ooa0RU9Da+9Q651YpUnkZzpwv0/uJIgJZiDIcqS6d88=; b=Mf6JauAFFh8r8bgnxz927OTHB/jxEIzhEyoTQTL19f3aOCoJDsWlRbYDWoorpcC3u5 /cTnt2A3cMToFxV5mgtDFv650PA+LGofSZM39tPxL0wieKRUaAll15v+W/R8Qr4LaUe2 X//Tu4VLYmXdsD1Iu0inTb22hRYu6499mxh3Y=
In-reply-to: <>
References: <> <> <>
User-agent: Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv: Gecko/20101027 Fedora/3.0.10-1.fc12 Thunderbird/3.0.10

It may not have been evident when you committed this (commit a5c86e986f0b2fe779f13cf53ce6e9f467b03950), but there was considerable discussion around this patch.

Andrew had taken into his tree a couple of patches to make the definitions that David Rientjes is removing safer:

David objected, but Andrew wasn't convinced, see all the replies to this patch but especially:

On 11/17/2011 03:22 PM, David Rientjes wrote:
Dummy, non-zero definitions for HPAGE_MASK and HPAGE_SIZE were added in
51c6f666fceb ("mm: ZAP_BLOCK causes redundant work") to avoid a divide
by zero in generic kernel code.

That code has since been removed, but probably should never have been
added in the first place: we don't want HPAGE_SIZE to act like PAGE_SIZE
for code that is working with hugepages, for example, when the dependency
on CONFIG_HUGETLB_PAGE has not been fulfilled.

Because hugepage size can differ from architecture to architecture, each
is required to have their own definitions for both HPAGE_MASK and
HPAGE_SIZE.  This is always done in arch/*/include/asm/page.h.

So, just remove the dummy and dangerous definitions since they are no
longer needed and reveals the correct dependencies.  Tested on
architectures using the definitions with allyesconfig: x86 (even with
thp), hppa, mips, powerpc, s390, sh3, sh4, sparc, and sparc64, and
with defconfig on ia64.

This whole comment strikes me as somewhat dishonest, as at the time David Rientjes wrote it, he knew that there were dependencies on these symbols in the linux-next tree.

Now we can add these:
+#define HPAGE_SHIFT    ({ BUG(); 0; })
+#define HPAGE_SIZE     ({ BUG(); 0; })
+#define HPAGE_MASK     ({ BUG(); 0; })

To the different architecture header files instead of having them in the common include/linux/hugetlb.h

If this is the way Linus wants it, I can live with that. But it was a little surprising to see that this was merged when there were strong arguments against it.

David Daney

Cc: Robin Holt<>
Cc: David Daney<>
Signed-off-by: David Rientjes<>
  include/linux/hugetlb.h |    5 -----
  1 files changed, 0 insertions(+), 5 deletions(-)

diff --git a/include/linux/hugetlb.h b/include/linux/hugetlb.h
--- a/include/linux/hugetlb.h
+++ b/include/linux/hugetlb.h
@@ -110,11 +110,6 @@ static inline void copy_huge_page(struct page *dst, struct 
page *src)

  #define hugetlb_change_protection(vma, address, end, newprot)

-#ifndef HPAGE_MASK
-#define HPAGE_MASK     PAGE_MASK               /* Keep the compiler happy */
  #endif /* !CONFIG_HUGETLB_PAGE */

  #define HUGETLB_ANON_FILE "anon_hugepage"

<Prev in Thread] Current Thread [Next in Thread>