[Top] [All Lists]

Re: select() to /dev/rtc0 to wait for clock tick timed out

To: john stultz <>
Subject: Re: select() to /dev/rtc0 to wait for clock tick timed out
From: Matt Turner <>
Date: Fri, 19 Aug 2011 15:41:59 -0400
Dkim-signature: v=1; a=rsa-sha256; c=relaxed/relaxed;; s=gamma; h=mime-version:in-reply-to:references:from:date:message-id:subject:to :cc:content-type; bh=jpxH/l+NFJn4EN0Xpcja3fHyMtVWE7cr3rbhND92qAg=; b=pX3BRUYT2qV2RhCuy/NyPG6UhDKKUm+0R2CYnLulNtxb7ue9MTC3ARDjtg0OiQaSXg b6ft+k3xIFDn5v9L7cztHn2Ata4pDYSU8Y7s+KHDsel9fBHCmeTuRqk9R+XtOMRw5N5Z SgofhklyK9tQPvxjXSAQBr02oROZECbK00Zck=
In-reply-to: <1313777242.2970.131.camel@work-vm>
References: <> <1313777242.2970.131.camel@work-vm>
On Fri, Aug 19, 2011 at 2:07 PM, john stultz <> wrote:
> On Fri, 2011-08-19 at 00:16 -0400, Matt Turner wrote:
>> Hi John,
>> I just sent a patch series to linux-mips@ that enables the RTC on a
>> particular Broadcom MIPS motherboard (BCM91250A SWARM). The RTC is an
>> M41T80.
>> When I first found the patchset (it was originally sent a a few years
>> ago) and applied it to 2.6.37, it worked perfectly.
>> Applied to 3.x (and I think even 2.6.38) I get the following when I run 
>> hwclock:
>> # hwclock --systohc
>> select() to /dev/rtc0 to wait for clock tick timed out
> So do alarm interrupts actually work on the hardware?
> The rtc-m41t80.c driver looks like it should support them ok.
> Does the test program at the end of Documentation/rtc.txt do much?
> thanks
> -john

Counting 5 update (1/sec) interrupts from reading /dev/rtc0:

... and then it doesn't count.

Would it help if I tried to bisect this? (Is there an easy way to
bisect 2.6.37..master with my patches applied to each iteration?)


<Prev in Thread] Current Thread [Next in Thread>