[Top] [All Lists]

select() to /dev/rtc0 to wait for clock tick timed out

To: john stultz <>
Subject: select() to /dev/rtc0 to wait for clock tick timed out
From: Matt Turner <>
Date: Fri, 19 Aug 2011 00:16:14 -0400
Dkim-signature: v=1; a=rsa-sha256; c=relaxed/relaxed;; s=gamma; h=mime-version:from:date:message-id:subject:to:cc:content-type; bh=kjKVTMNZ7lxCzamrq6wMO7f2Qx33HIRvJIk8bn+iXzE=; b=f8OEOv6PUgkUANhtuT8Ut8pmjp8iwSj1MwIgrjI8fr/jl+4gVunPXvNy10yXA9aty/ rSoRbyOXcQVnQ+A+yJYjXeqGWaWSOtItAnz6kfBQMZRlXGu7lop1uIq7Xet8aPugylHF Wxe9RYkNrU35RPghclcisH8NYUBwPnPcmyTJ0=
Hi John,

I just sent a patch series to linux-mips@ that enables the RTC on a
particular Broadcom MIPS motherboard (BCM91250A SWARM). The RTC is an

When I first found the patchset (it was originally sent a a few years
ago) and applied it to 2.6.37, it worked perfectly.

Applied to 3.x (and I think even 2.6.38) I get the following when I run hwclock:

# hwclock --systohc
select() to /dev/rtc0 to wait for clock tick timed out

dmesg shows:

[    1.068000] i2c /dev entries driver
[    1.072000] i2c-sibyte: i2c SMBus adapter module for SiByte board
[    1.080000] rtc-m41t80 1-0068: chip found, driver version 0.06
[    1.088000] rtc-m41t80 1-0068: rtc core: registered m41t81 as rtc0
[    1.172000] rtc-m41t80 1-0068: setting system clock to 2011-08-18
19:56:53 UTC (1313697413)

I'm emailing you because I thought it might be the same problem as

Do you know what might be the problem?

The patch series can be found here [1], if they did not find their way
to you through another mailing list.



<Prev in Thread] Current Thread [Next in Thread>