[Top] [All Lists]

Re: Mega rename of device tree routines from of_*() to dt_*()

To: David Daney <>
Subject: Re: Mega rename of device tree routines from of_*() to dt_*()
From: Grant Likely <>
Date: Wed, 24 Nov 2010 11:02:41 -0700
Cc: Stephen Neuendorffer <>,, LKML <>, linux-mips <>,,, linuxppc-dev list <>,
In-reply-to: <>
Original-recipient: rfc822;
References: <1290607413.12457.44.camel@concordia> <fa44e045-9600-4c46-939a-af246afab4f6@VA3EHSMHS019.ehs.local> <>
On Wed, Nov 24, 2010 at 10:18 AM, David Daney <> wrote:
> On 11/24/2010 09:02 AM, Stephen Neuendorffer wrote:
>>> -----Original Message-----
>>> From:
>>> [mailto:linuxppc-dev-
>>>] On Behalf Of Michael
>>> Ellerman
>>> Sent: Wednesday, November 24, 2010 6:04 AM
>>> To: LKML
>>> Cc: linux-mips;;
>>>; linuxppc-dev
>>> list;
>>> Subject: RFC: Mega rename of device tree routines from of_*() to dt_*()
>>> Hi all,
>>> There were some murmurings on IRC last week about renaming the of_*()
>>> routines. I was procrastinating at the time and said I'd have a look at
>>> it, so here I am.
>>> The thinking is that on many platforms that use the of_() routines
>>> OpenFirmware is not involved at all, this is true even on many powerpc
>>> platforms. Also for folks who don't know the OpenFirmware connection it
>>> reads as "of", as in "a can of worms".
>>> Personally I'm a bit ambivalent about it, the OF name is a bit wrong so
>>> it would be nice to get rid of, but it's a lot of churn.
>>> So I'm hoping people with either say "YES this is a great idea", or "NO
>>> this is stupid".
>> Personally, I think it's a great idea, if only because I stared long and
>> hard
>> at the code once upon a time trying to figure out what is really
>> OF-related
>> and what isn't.  It's somewhat clearer now that drivers/of has been
>> factored
>> out (although, shouldn't it be drivers/dt???)

Yes, the directory name should change, as should the CONFIG_OF* defines.

>> That said, it *is* alot of code churn.  If it's going to be done, I think
>> it should be
>> done in concert with fixing a bunch of the function names which don't
>> really follow any
>> sane naming convention, so that the backporting discontinuity only happens
>> once.
> Oh, you mean things like:
> of_{,un}register_platform_driver vs. platform_driver_{,un}register
> That one is particularly annoying to me.

Ignore that one.  of_{,un}platform_driver is deprecated and users will
all be converted to platform_drivers.


<Prev in Thread] Current Thread [Next in Thread>