[Top] [All Lists]

Kernel not booting in QEMU_SYSTEM_MIPS

Subject: Kernel not booting in QEMU_SYSTEM_MIPS
From: soumyasr <>
Date: Mon, 17 May 2010 21:42:09 -0700 (PDT)
Original-recipient: rfc822;
Hi all,

   I am new to qemu as well as mips..

1)   I Downloaded the qemu latest version from and installed it
After that i downladed mips-test-0.2.tar.gz from and followed the below
commands to boot the kernel
and root file system ....

$ tar zxvf mips-test-0.2.tar.gz
$ cd mips-test
$ qemu-system-mips -M mips -kernel vmlinux-2.6.18-3-qemu -initrdinitrd.gz

When I run the above command

Qemu is launching and nothing else happen. I don't have any error, but I
don't have prompt... It seems that nothing is booting.. I tried the same
with ARM
instead if mips it boots the kernel, rfs and got the login prompt.. Since i
am not getting any errors i am able to figure out what's the problem is???

2)  I tried to build our own customized kernel using the buildroot by
executing the command :
    $ makemenuconfig

Here is the buildroot configuration  :
- Target Architecture => MIPSEL
- Target architecture variant =>mips I (generic)
- Target ABI => o32
- Target Option => default configuration
- Build option => default configuration
- Toolchain => Include target utils in cross toolchain  and build gdb server
for the target
- Package selection => default configuration
- Target file system => cpio (gzip compression)
- Kernel => Same version as linux header
- config file => .config
- kernel binary format => zImage

  when i run the command make to build the kernel i get the following error

rm -rf /home/soumya/buildroot/output/build/buildroot-config
mkdir -p /home/soumya/buildroot/output/build
cp -dpRf package/config/buildroot-config
/usr/bin/make -j1 -C /home/soumya/buildroot/output/toolchain/uClibc-0.9.31 \
                ARCH="mips" \
                PREFIX= \
                DEVEL_PREFIX=/ \
                RUNTIME_PREFIX=/ \
                HOSTCC="/usr/lib/ccache/gcc" \
make[1]: Entering directory
mipsel-unknown-linux-uclibc-gcc: libgcc.a: No such file or directory
make[1]: *** [lib/] Error 1
make[1]: Leaving directory
make: *** [/home/soumya/buildroot/output/toolchain/uClibc-0.9.31/lib/libc.a]
Error 2

          Please anybody can help me out to resolve it if I am doing
anything wrong..

Best Regards,

View this message in context:
Sent from the linux-mips main mailing list archive at

<Prev in Thread] Current Thread [Next in Thread>