[Top] [All Lists]

Qube2 slowly dies

Subject: Qube2 slowly dies
From: Glyn Astill <>
Date: Wed, 10 Jun 2009 14:04:03 +0000 (GMT)
Dkim-signature: v=1; a=rsa-sha256; c=relaxed/relaxed;; s=s1024; t=1244642643; bh=CHyneAIaRrsLcyop2kIpTnMxX+HIGrENFrLM6nTI55g=; h=Message-ID:X-YMail-OSG:Received:X-Mailer:Date:From:Subject:To:MIME-Version:Content-Type:Content-Transfer-Encoding; b=X+5wE9iAXogeUYF5d2SgcU0m5x78hNgjYMnEsGVnXWW2cTjWgJOMHICQMDBHwzEPOBl4BzzlCZj8I/D2+xrP4wqDNFgS+ly5Ny1JO3yr+gq8bEUrszXRQhFu90qSzro9JMX36I2VcoGkK5a9tznEoZW22h72/zYtDC5w/TGtBlQ=
Domainkey-signature: a=rsa-sha1; q=dns; c=nofws; s=s1024;; h=Message-ID:X-YMail-OSG:Received:X-Mailer:Date:From:Subject:To:MIME-Version:Content-Type:Content-Transfer-Encoding; b=E+PHTiFd9SQSc5+w+VoRF8qvM8iS/L2KgGqeSd9DINJw0EegKT+fgWdOmYWMq1whBsH7hvWoOFSAKwF55EY7bDR8/a//DjPFNEz6VuoqX3MXWZkMpBRd86x0HgUWWw/GhNEGLfhO2rtYO4STe0wev2Jhp+rbZVU2jmP8EqjAoOQ=;
Original-recipient: rfc822;
Hi people,

I've been directed here from the Debian lists by Martin Michlmayr. I'm running 
lenny on a qube2 128mb ram / 40gb disk.

I've tried kernels 2.6.26 and 2.6.30~rc8 and the issue I'm about to describe is 
present in both, I haven't tried any other kernels - but I will try 2.6.22 when 
I can.

Essentially the machine gets more and more sluggish until it finally dies. I've 
had a quick look in meminfo and I can't see that it's running out of memory, 
and I'm not sure what else to check?

I find it hard to describe what's going off, but here's a scenario I hope 
illustrates the problem. The configure script is just an example of doing 
something - I could easily have extracted an archive with tar or something for 
the same results;

- I start 2 ssh sessions and in one start configure for the postgres source, in 
the other I just started top.

- And for a while all seems fine; configure ticks away and top refreshes every 

- Then top stops ticking over - but it'll refresh with a keypress. Anyway I 
exit top and try to run it again... nothing. I hit ctrl-c which brings me back 
to the prompt and I try again... nothing.

- The configure script is still ticking over slowly.

- I try "ps ax" - it works; so I try it again... nothing.

- I try "ipcs" and "lsof" they both work and seem to keep working.

- I try "ps ax" again... nothing. I hit ctrl-c and now it doesn't come back to 
the command prompt for a while.. say 5 minutes and eventually it's back.

- It's still going. Some commands still work, some just do nothing. 
proc/meminfo shows it's not eaten all the memory.

- If I try to start another ssh session I can log in, I get the motd, but I 
don't get to the shell.

- Eventually the configure script ends, and all shells come back to the prompt. 
But it now seems totally braindamaged, I can run "ps ax" but "top" and other 
commands still do nothing. Heres strace attached to the top process:

deb:~# strace -p 7228
Process 7228 attached - interrupt to quit
_newselect(0, NULL, NULL, NULL, {0, 500013}

- Then after a little while the whole thing becomes unresponsive.

Can anyone confirm they've seen the same behaviour or direct me what to look 



<Prev in Thread] Current Thread [Next in Thread>