[Top] [All Lists]

Re: Au1200 and NAND Flash - K9F1G08U0A -

Subject: Re: Au1200 and NAND Flash - K9F1G08U0A -
From: Frank Neuber <>
Date: Thu, 12 Feb 2009 08:55:37 +0100
In-reply-to: <>
Original-recipient: rfc822;
References: <>
Hi Bora,
I have the same problem here.
Did you find a solution for this nand large page device.
I tried to copy nand_command_lp from nand_base.c and added the -CE stuff
including disabling interrupts during read.
The result is that I found just one bad block during scan :-). Also
erasing nand seems to be possible (usinf eraseall /dev/mtdX).
But if I write and read back the data (using dd) I get io errors :-(

I found your posting on this list wihout an answer so I hope you was
able to manage the nand stuff.

Kind Regards,

Am Samstag, den 19.05.2007, 22:13 +0300 schrieb
> Hi,
> We want to use NAND flash on Alchemy Au1200 and have a custom board along 
> with 
> Db1200; so tried it both on our custom board and Db1200 without success.
> (Because Db1200 has a slot we opened it and replaced the original with our 
> part)
> Kernel -> Error messages:
> NAND device: Manufacturer ID: 0xec, Chip ID: 0xf1 (Samsung NAND 128MiB 3,3V 
> 8-bit)
> Scanning device for bad blocks
> Bad eraseblock 0 at 0x00000000
> Bad eraseblock 1 at 0x00020000
> ...
> Bad eraseblock 1022 at 0x07fc0000
> Bad eraseblock 1023 at 0x07fe0000
> Creating 2 MTD partitions on "NAND 128MiB 3,3V 8-bit":
> It marks all the eraseblocks as BAD. As far as I understand 
> "au1xxx_nand_command" seems doesnt work correctly. Has someone succeded to 
> work with these large block parts in the Au1200/Au1550?
> Thanks...
> --
> Bora SAHIN

<Prev in Thread] Current Thread [Next in Thread>