[Top] [All Lists]

Re: Au1550 with kernel linux- (SOLVED)

To: Manuel Lauss <>
Subject: Re: Au1550 with kernel linux- (SOLVED)
From: Frank Neuber <>
Date: Sun, 25 Jan 2009 09:20:16 +0100
In-reply-to: <1232839224.28527.336.camel@t60p>
Original-recipient: rfc822;
References: <1232739600.28527.289.camel@t60p> <> <1232787448.28527.302.camel@t60p> <1232839224.28527.336.camel@t60p>
Hi List,
after a sleepness nigth I got an idea ....
Because I need an uImage I had to build a Image first.

The buildprocess of the kernel call this wrong line
mips_4KCle-objcopy  --remove-section=.reginfo  vmlinux arch/mips/boot/Image
if I add this rule in the Makefile
$(obj)/Image: $(VMLINUX) FORCE
        $(call if_changed,objcopy)
        @echo '  Kernel: $@ is ready'
On older kernelversions this works well!

The rigth one is this:
mips_4KCle-objcopy -O binary -R .note -R .comment -S  vmlinux 

I typed the last steps by hand for now and it works
gzip -f -9 < arch/mips/boot/Image > arch/mips/boot/zImage
/bin/sh /tmp/linux- -A mips -O linux -T kernel -C 
gzip -a 0x80100000 -e 0x80104690 -n 'Linux-' -d arch/mips/boot/zImage 
(keep in mind the -a 0x80100000 -e 0x80104690 parameters are greped from 
vmlinux with 
TEXT_ADDR       := $(shell awk '/_text/ { printf "0x%s", $$1 ; exit }' < 
ENTRY_ADDR      := $(shell awk '/kernel_entry/ { printf "0x%s", $$1 ; exit }' < 

Than I can see my first early printk messages :-) huhuuu

Now I can work on.

BTW: why is uImage not supported by the kernel build system for MIPS?


<Prev in Thread] Current Thread [Next in Thread>