[Top] [All Lists]

Re: AU1100 2.4.21-pre4 flash disks problems

To: LD <>
Subject: Re: AU1100 2.4.21-pre4 flash disks problems
From: Markus Gothe <>
Date: Fri, 21 Mar 2008 20:50:31 +0100
In-reply-to: <>
Original-recipient: rfc822;
References: <>
Have you tried with 2.4.21 (not pre4), if not start there then try 2.4.22 and see if it works. The USB-layer in 2.4 around that time being was pretty immature IIRC.


On 21 Mar 2008, at 17:22, LD wrote:
Hash: SHA1

Hi all,
I am working on an AU1100 system, using a 2.4.21-pre4 kernel. Filesystem
is jffs2, uclibc libraries.

I have a couple of problems with USB flash disk handling:

1) it seems that my system does not "see" disks larger than 512 MB. 1GB
disks or more cannot be mounted. This is becoming a problem because
512MB disks are going out of the market.

2) Given two flash disks of different sizes (for example: one 128 MB,
one 512 MB), if I mount/umount one of them -> I cannot then mount the
other and vice versa.

- - mount the 128 MB one, then umount. Try to mount the 512MB ->fail.
- - reset the device
- - mount the 512MB device, ok. Umount. Try to mount the 128MB -> fail.

Disks are vfat formatted ; did not try with other filesystem types.

Tried to use a 2.6.x kernel and no problem ; I am planning to switch all
to 2.6.x kernel, but in this moment for me is better (if possible)
fixing this problem, because I have a number of applications and drivers
running on 2.4.21 and the switching to 2.6.x means revising and
re-testing a lot of things.

Back to 2.4.21...
If I try to dmesg I see a "Partition check:" message missing when I put
in the second disk ; I am investigating on this (maybe some piece of
software is called checking for partitions on the first disk but is not
called again when I change disk type).

Any suggestions are welcome,

best regards

Lucio Dona'
Version: GnuPG v1.4.6 (GNU/Linux)
Comment: Using GnuPG with Mozilla -



Mr Markus Gothe
Software Engineer

Phone: +46 (0)13 21 81 20 (ext. 1046)
Fax: +46 (0)13 21 21 15
Mobile: +46 (0)70 348 44 35
Diskettgatan 11, SE-583 35 Linköping, Sweden

Attachment: PGP.sig
Description: This is a digitally signed message part

<Prev in Thread] Current Thread [Next in Thread>