[Top] [All Lists]

Re: MIPS prelink question

To: Hiroki Kaminaga <>
Subject: Re: MIPS prelink question
From: Thiemo Seufer <>
Date: Tue, 18 Mar 2008 11:19:15 +0000
In-reply-to: <>
Original-recipient: rfc822;
References: <>
User-agent: Mutt/1.5.17+20080114 (2008-01-14)
Hiroki Kaminaga wrote:
> Hi!
> I'm not sure if this is the right ML to ask, but since I've found
> discussion about MIPS prelink here, I'm posting here...

The binutils list would be a better place.

> In the below thread, patch for MIPS prelink was posted.
> I've tried this patch, but I got below error when I tried to do prelink.
>       No space in ELF segment table to add new ELF segment

A bit more of the output would help with isolating the problem.
Anyway, IIRC there are two effects which cause this error:
 - Linking in binary objects which were built by a toolchain without
   prelink support, probably one of the compiler-internal startup files.
 - Use of an older version on binutils (from the time when the prelink
   patches went in), which still had a few issues with handling the
   additional segment.

> On the montavista pro 5.0 note, I found that they have fixed above
> prelink error, but I could not find the patch. Could someone give
> me pointer to address this issue?

I believe binutils 2.18 works fine WRT prelinking. I don't remember
the particular patches to watch out for, though.


<Prev in Thread] Current Thread [Next in Thread>