[Top] [All Lists]

Re: iomemory causing a data bus error

Subject: Re: iomemory causing a data bus error
From: Jon Dufresne <>
Date: Thu, 07 Feb 2008 15:32:56 -0500
In-reply-to: <1202397602.3298.25.camel@localhost>
Original-recipient: rfc822;
References: <1202397602.3298.25.camel@localhost>
I took some time and wrote a VERY simplified driver. The driver is now
doing only the required steps to test this error. I figured this would
localize the problem as much as possible. When I run this new driver. I
now see the following error:

ohci_hcd 0000:00:09.0: OHCI Unrecoverable Error, disabled
ohci_hcd 0000:00:09.0: HC died; cleaning up
irq 55: nobody cared (try booting with the "irqpoll" option)
Disabling IRQ #55

It looks to me like there is a problem with the USB driver. An
interesting note is that my device's interrupt is also irq 55. I have
tried this simplified driver both requesting the interrupt, in which
case it is never triggered, and not requesting the interrupt. Both cases
end the same way. After I get that message the system is still running,
but extremely slowly.

Any ideas?


<Prev in Thread] Current Thread [Next in Thread>