[Top] [All Lists]

Re: [MIPS] Build an embedded initramfs into mips kernel

To: "Willy Tarreau" <>
Subject: Re: [MIPS] Build an embedded initramfs into mips kernel
From: "Alon Bar-Lev" <>
Date: Wed, 19 Dec 2007 20:46:46 +0200
Cc: "H. Peter Anvin" <>,, LKML <>
Dkim-signature: v=1; a=rsa-sha256; c=relaxed/relaxed;; s=gamma; h=domainkey-signature:received:received:message-id:date:from:to:subject:cc:in-reply-to:mime-version:content-type:content-transfer-encoding:content-disposition:references; bh=SLMmRrTckla286sGvvaUhAbsjLQ4JakEImd3agdLa00=; b=Xvqpw/kA/E5F9jfDGaJyCujLYjoodnGmnHWob0m1uvoPEDXf0t7G9JjvndWDxJOt5cheNNAn5se2hDH/MULrGD9tCync67D0LpPGB9jTJwPFdTCDYRJ/faPStjl2dBGOw7MTa4fM2jJKD+9+tKvyVh+dW5vbRm00BNlGDCgkTSQ=
Domainkey-signature: a=rsa-sha1; c=nofws;; s=gamma; h=message-id:date:from:to:subject:cc:in-reply-to:mime-version:content-type:content-transfer-encoding:content-disposition:references; b=W+6XGkLPXx4O3VCNPZaU+JgVNj16fdkTs5gU8yH/Iszf/1O1Spnu6eFzNQq9oCRnbjY5G9PAy+UyFSbrSkq+9C5C36x3yk0JxbsZtI8hwMMxm7K7BeQCjYSlNEz6Atyq7fCQDZGS7Gatv0FVCC7/xmYEytFZo/RqTAwxCVyO/G4=
In-reply-to: <>
Original-recipient: rfc822;
References: <> <> <> <>
Thank you for your help.
Indeed the dynamic loader of uclibc is the cause.
I upgraded to latest uclibc-0.9.29, and finally the files was linked
against uclibc's ld.
But it did not work...
Tried to run a dynamic linked executable via static shell, and got
floating point exception.
Tried to compile toolchain and uclibc with softfloat, but still did not work.
So I moved to glibc and all works correctly.

Thank you for quick response!
I will continue the discussion at uclibc lists.

Best Regards,
Alon Bar-Lev.

On 12/19/07, Willy Tarreau <> wrote:
> On Wed, Dec 19, 2007 at 12:09:46AM +0200, Alon Bar-Lev wrote:
> > On 12/18/07, H. Peter Anvin <> wrote:
> > > Make sure your /init doesn't depend on an interpreter or library which
> > > isn't available.
> >
> > Thank you for your answer.
> >
> > I already checked.
> >
> > /init is hardlink to busybox, it depends on which is available at 
> > /lib
> Are you sure that is enough and that you don't need any ?
> > But shouldn't I get a different error code if this is the case?
> If it does not find part of the dynamic linker or libraries, this error
> makes sense to me.
> You should try to build a static init with any stupid thing such as a
> hello world to ensure that the problem really comes from the init and
> nothing else.
> Regards,
> Willy

<Prev in Thread] Current Thread [Next in Thread>