[Top] [All Lists]

Re: Unknown symbol register_framebuffer

To: "Geert Uytterhoeven" <>
Subject: Re: Unknown symbol register_framebuffer
From: kaka <>
Date: Fri, 12 Oct 2007 20:26:26 +0530
Dkim-signature: v=1; a=rsa-sha256; c=relaxed/relaxed;; s=beta; h=domainkey-signature:received:received:message-id:date:from:to:subject:in-reply-to:mime-version:content-type:references; bh=44MSdf5+IVIPme0ie5pzQ+LRhRFgsVs1MD5J1q8s4Vs=; b=U2UZ9oiXvMfqoTnWe6Iz1QHmo4SHBBq3YIBd46/f8Rf0L5PnEaKgsun4Jx97ktOz3M4lXHqoWX21Nm19n03SLCIsrn2QX3mxsdt4VD8RC+gNKzgWYAIod1A2CMwHei7nYOJm6uuh31DJ1WNizdjI/wgAYf5N+lqfN7vM02fppPY=
Domainkey-signature: a=rsa-sha1; c=nofws;; s=beta; h=received:message-id:date:from:to:subject:in-reply-to:mime-version:content-type:references; b=Uxl2Hq8qZ+QZ00WnAdn+EkhEg2sud6JHyPWuNB4zJVR2dPzcjIbsz1OXBtjgUvslOqqOwihU94/qIGdvQBJZyTo/gkm9l70TxJldZfXhnwfkekUbc4Ebad5ubwJ3cUcMudnTQLZR/WibIDt9A+CHGvWH+hNdXd5b7QASPXyHKow=
In-reply-to: <Pine.LNX.4.64.0710121513560.7335@anakin>
Original-recipient: rfc822;
References: <> <Pine.LNX.4.64.0710121513560.7335@anakin>
Resent-date: Fri, 12 Oct 2007 20:11:54 +0200 (CEST)
Resent-from: Geert Uytterhoeven <>
Resent-message-id: <Pine.LNX.4.64.0710122011540.15951@anakin>
Resent-subject: Re: Unknown symbol register_framebuffer
Resent-to: Linux/MIPS Development <>
Hi Geert,
Thanks for the reply.
Actually we are the writer of the device driver file.
We don't have any supplier.
Although we have all the library and .so files.
But it is not able to find the above mentioned symbols in the kernel table.
COuld you plz let us know how to link the kernel symbol so that the KLM brcmstfb.ko can find the symbols?
Thanks & Regards,

On 10/12/07, Geert Uytterhoeven <> wrote:
On Fri, 12 Oct 2007, kaka wrote:
> > WHile installing framebuffer driver for BCM chip in MIPS platform(cross
> > compiled in intel 86).
> > I am getting the following error.
> >
> Since it is cross compiled and running on MIPS platform, the linux doesn't
> support modinfo command to find the dependencies.

Really? I just tried `modinfo' of an ia32 box on a cross-compiled module
for a ppc64 box, and it worked fine.

> > # insmod brcmstfb.ko
> > brcmstfb: Unknown symbol unregister_framebuffer
> > brcmstfb: Unknown symbol printf
> > brcmstfb: Unknown symbol __make_dp
> > brcmstfb: Unknown symbol malloc
> > brcmstfb: Unknown symbol framebuffer_alloc
> > brcmstfb: Unknown symbol fb_find_mode
> > brcmstfb: Unknown symbol fb_dealloc_cmap
> > brcmstfb: Unknown symbol brcm_dir_entry
> > brcmstfb: Unknown symbol register_framebuffer
> > brcmstfb: Unknown symbol fb_alloc_cmap
> > brcmstfb: Unknown symbol framebuffer_release
> > brcmstfb: Unknown symbol free

As mentioned before, please talk to the supplier of your module about these
references to `printf', `malloc', and `free'.



Geert Uytterhoeven -- There's lots of Linux beyond ia32 --

In personal conversations with technical people, I call myself a hacker. But
when I'm talking to journalists I just say "programmer" or something like that.
                                                           -- Linus Torvalds

Thanks & Regards,
<Prev in Thread] Current Thread [Next in Thread>