[Top] [All Lists]

Re: Exception while loading kernel

To: Giuseppe Sacco <>
Subject: Re: Exception while loading kernel
From: "J. Scott Kasten" <>
Date: Thu, 6 Sep 2007 06:58:15 -0400 (EDT)
Domainkey-signature: a=rsa-sha1; q=dns; c=nofws; s=s1024;; h=Received:X-YMail-OSG:Date:From:X-X-Sender:To:cc:Subject:In-Reply-To:Message-ID:References:MIME-Version:Content-Type; b=GHMmS0rPjgU+BlCPpujBbg0qaKvP2qwFOrXNDhXrXNWIC+FCGP5dz217RChx2MtG9n5KBwD1dsCL5y8C7E0JlzSZHy9YHYKhWQ+w/cye/yw5HX2lPYoZkDD8a2VV4fHPwI5sm9/r/sMiYvR7fLbAPP6w0bI+gwnTM23w/UTRYVs= ;
In-reply-to: <1188481891.6770.22.camel@scarafaggio>
Original-recipient: rfc822;
References: <1188030215.13999.14.camel@scarafaggio> <> <> <> <> <1188481891.6770.22.camel@scarafaggio>

Hi Giuseppe,

I think I'm getting a clue what is happening to your kernel. Would you please do an "ls -l" in your /boot and tell me exactly HOW BIG your and kernel files are? :)

I took your config as is from the link below and pulled the linux-mips source, built it and then made a fascinating discovery when I tried to set it up for a boot.

The was OVER 50 MEGS, and the kernel weighed in at a HEFTY 87 MEGS.

In the various parts of the kernel config, you will see some options for the kernel sysmbol table, driver symbols, etc... Try turning some of those off. In particular, I noticed in your config:


I suspect you are stressing things that haven't been looked at lately.

Anyway, rebuild with some things turned off, and let us know if your little blue box still explodes.



On Thu, 30 Aug 2007, Giuseppe Sacco wrote:

Il giorno gio, 30/08/2007 alle 09.37 -0400, J. Scott Kasten ha scritto:

Let's review for just a second.  If I understand, you are booting the
debian pre-built 2.6.18-4 just fine.  However, any kernel you build
yourself seems to be borked.  Correct?

No, I may rebuild 2.6.18 just fine. I even added a few device drivers
without problems. Lately I tried a more recent kernel, i.e. and 2.6.23-rc3, bot no one of them seems to boot on an SGI O2.

You don't need to spam the list with it, but please gzip one or more of
your .config files, label them as to kernel version, and email me direct
off list.  I would like to try and recreate your problem and see what can
be learned here.

you may get the config (for download from from


To UNSUBSCRIBE, email to
with a subject of "unsubscribe". Trouble? Contact

<Prev in Thread] Current Thread [Next in Thread>