[Top] [All Lists]

Re: Problems with NFS boot

Subject: Re: Problems with NFS boot
From: ankur maheshwari <>
Date: Wed, 08 Aug 2007 17:57:29 +0530
Cc: Ralf Baechle <>,
In-reply-to: <>
Original-recipient: rfc822;
References: <> <> <>
User-agent: Thunderbird (Windows/20061207)
Please try similar to this working example; I use it successfully in my case.

setenv bootargs root=/dev/nfs rw nfsroot= ip=

If booting from u-boot I use this following
root=/dev/nfs rw nfsroot=\\$(serverip):/opt/target ip=\\$(ipaddr):\\$(serverip):\\$(gatewayip):\\$(netmask):\\$(hostname)::off


Mohamed Bamakhrama wrote:
Hi Ralf,
I added the ":" at the end. It is still not working. I get the same error:

VFS: Cannot open root device "<NULL>" or unknown-block(0,0)
Please append a correct "root=" boot option; here are the available partitions:
Kernel panic - not syncing: VFS: Unable to mount root fs on unknown-block(0,0)

Do I have to set any special config. info in the the kernel config
beside the NFS support?

On 8/8/07, Ralf Baechle <> wrote:
On Wed, Aug 08, 2007 at 12:18:51PM +0200, Mohamed Bamakhrama wrote:

Hi list,
I have a Malta board for which I was able to build the kernel, load it
and start it. The problem comes when it tries to boot through the NFS.

I start the kernel with the following command:
go . nfsroot= ip=
                        ^^ there should be a `:' following the IP.


<Prev in Thread] Current Thread [Next in Thread>