[Top] [All Lists]

Re: Problems with NFS boot

To: "Ralf Baechle" <>
Subject: Re: Problems with NFS boot
From: "Mohamed Bamakhrama" <>
Date: Wed, 8 Aug 2007 13:31:26 +0200
Dkim-signature: a=rsa-sha1; c=relaxed/relaxed;; s=beta; h=domainkey-signature:received:received:message-id:date:from:reply-to:to:subject:cc:in-reply-to:mime-version:content-type:content-transfer-encoding:content-disposition:references; b=hHjpFnB5ZoCcKTjExnUilzUuga8GHZzB0POINW72oohmRoZ8ePmZXMqGfElx8wI8ZMVAd33ppWto8FbdQJtTxNB9yUMV+FgI8wtRtceXE3zr1WvDN4VlCHESgOUZ6L8hWMvdRVkOpEsClyh+Txl3LVIX2B3AieAnjLvYrowElqg=
Domainkey-signature: a=rsa-sha1; c=nofws;; s=beta; h=received:message-id:date:from:reply-to:to:subject:cc:in-reply-to:mime-version:content-type:content-transfer-encoding:content-disposition:references; b=QHzSteNqnVJscun/4diki7kqqHfVO14zmRT8KhO++G6v8KXW/mqAU0RPCdz8dmYn/kkB7w20u7QauIsbPG8m9U5pyyWVUvlOIwn+0aut0QwhiyyM2TdXwBzN4lTAAduqXznlVhVuAgB1NCumkPZyJMNBs2Fw8UeRE6NkN6uJ7EA=
In-reply-to: <>
Original-recipient: rfc822;
References: <> <>
Hi Ralf,
I added the ":" at the end. It is still not working. I get the same error:

VFS: Cannot open root device "<NULL>" or unknown-block(0,0)
Please append a correct "root=" boot option; here are the available partitions:
Kernel panic - not syncing: VFS: Unable to mount root fs on unknown-block(0,0)

Do I have to set any special config. info in the the kernel config
beside the NFS support?

On 8/8/07, Ralf Baechle <> wrote:
> On Wed, Aug 08, 2007 at 12:18:51PM +0200, Mohamed Bamakhrama wrote:
> > Hi list,
> > I have a Malta board for which I was able to build the kernel, load it
> > and start it. The problem comes when it tries to boot through the NFS.
> >
> > I start the kernel with the following command:
> > go . nfsroot= ip=
>                         ^^ there should be a `:' following the IP.
>  Ralf

Mohamed A. Bamakhrama
Am Schaeferanger 15, room 035
85764 Oberschleissheim, Germany
Mobile: +49-160-9349-2711

<Prev in Thread] Current Thread [Next in Thread>