[Top] [All Lists]

Re: Fwd: [RFC] SGI O2 MACE audio ALSA module

To: "" <>, "Linux MIPS List" <>
Subject: Re: Fwd: [RFC] SGI O2 MACE audio ALSA module
From: TJ <>
Date: Fri, 6 Jul 2007 09:30:34 +0100
Dkim-signature: a=rsa-sha1; c=relaxed/relaxed;; s=beta; h=domainkey-signature:received:received:message-id:date:from:to:subject:in-reply-to:mime-version:content-type:content-transfer-encoding:content-disposition:references; b=LY7rsAc8qT6xnlJaIHicLYSnpjQ/jCQNA1OWwHtY1VzWnCyitLjAy3b/Gvp1e3Lg3Dh6bp1kOGNzgFRUHdwzqn+wtls6VQYPuL2hbsioUYcrF+pmmsm8Al4H5EoT+RyJqjj1dCWf9kIG/YuX1+ADc7b/zxT8YVyzHhEgiuLgYOs=
Domainkey-signature: a=rsa-sha1; c=nofws;; s=beta; h=received:message-id:date:from:to:subject:in-reply-to:mime-version:content-type:content-transfer-encoding:content-disposition:references; b=jRksg4c7vBDWnYI0HTBKj2oO6/KJAY5YhbClz41b9w6L4e0ZpZCb9XP+j4mfTb5Ea2DKQ0VuhE/sLX/HAPLYXoXhF6y7ppRYd+nkYDdLiGMGu+/ylZ3uA9JhIkJ16eVS4eLkkDvtQPqXEmDuD6Nt/ppqXvrZw4ZCDB8rt615NYE=
In-reply-to: <>
Original-recipient: rfc822;
References: <> <> <>

On 06/07/07, <> wrote:
First off, thanks for your work on this.

I tried to compile with and Debian's gcc 4.1.1-27 cross-compiler.
The kernel compiled, but make modules failed with the errors below.
Something's definitely wrong with the typedefs and structs for use in a
newer kernel.

The compile errors is because ALSA have removed all the typedefs for
their structures in the header files, while my module still uses the
typedefs. As a short term fix grab include/sound/typedefs.h from an
older kernel.

I can see the case against other uses of typedef, but I really do not
see why typedef struct is so bad. seeing 'struct mything_s *foo;'
doesn't really tell you anything more about foo then 'mything_t *foo;'
does. If a typedef was something other then a struct then I would want
it to have an obvious name that said such, eg 'u64'. (I really don't
like 'size_t')

I also tried the linux-MIPS and while the kernel compiles it
doesn't boot.

I don't know why you can't get to boot, did you make sure
that CONFIG_BUILD_ELF64 is 'n'? That's been an issue that bit me.

At the moment my crossdev env is broken, but once I fixed it I will
get the latest lm.o kernel version and update the alsa stuff in my
module so that it will build.

Thanks for looking at the patch.


<Prev in Thread] Current Thread [Next in Thread>