[Top] [All Lists]

Re: SGI Octane kernel patches fail

Subject: Re: SGI Octane kernel patches fail
From: Jens Seidel <>
Date: Fri, 15 Dec 2006 00:09:30 +0100
Cc: Jens Seidel <>
In-reply-to: <20061214203535.GA18511@pluto>
Original-recipient: rfc822;
References: <20061214203535.GA18511@pluto>
User-agent: Mutt/1.5.13 (2006-08-11)
On Thu, Dec 14, 2006 at 09:35:35PM +0100, Jens Seidel wrote:
> I tried to compile a newer 2.6.19-rc1 kernel and applied the two IOC3
> and IP30 patches from
> First of all
> the patch fails slightly and needs manual adjustments. Compiling results
> in an error, do_IRQ() is called with only one parameter instead of two.
> So I wonder what kernels are compatible with
> linux-mips-2.6.19-rc1-ip30-r28.patch.bz2. Do I need other patches as
> well? Also the kernel config file skylark-approved-config-tm in skylark/
> is out of date. It seems to match a 2.6.12 or similar version.
> PS: Please CC: me.

Ah, it works fine with linux-2.6.19 (it was trivial to crosscompile). So it
seems the names of the patches are just wrong.

I still fail to mount the root fs via NFS (tcpdump reports no network
transfer after loading the kernel) and to have root on a local hard disk:
[17179594.972000] XFS: file system using version 1 directory format
[17179595.044000] XFS: SB validate failed
[17179595.092000] VFS: Cannot open root device "sdb8" or unknown-block(8,24)
[17179595.172000] Please append a correct "root=" boot option
[17179595.240000] Kernel panic - not syncing: VFS: Unable to mount root fs on 

I need to check this "SB validation". But I'm sure I'm able to embed an
initrd into the kernel as this works already with the old Gentoo kernel.


<Prev in Thread] Current Thread [Next in Thread>