[Top] [All Lists]

Re: request_module: runaway loop modprobe net-pf-1

Subject: Re: request_module: runaway loop modprobe net-pf-1
From: mlachwani <>
Date: Wed, 22 Nov 2006 16:10:02 -0800
Cc: Ralf Baechle <>,
In-reply-to: <>
Original-recipient: rfc822;
References: <> <> <>
User-agent: Thunderbird (X11/20061025)
CONFIG_UNIX is defined in net/unix/Kconfig or simply do a "make menuconfig" and search for UNIX.

It depends on CONFIG_NET. Check your .config ...

Manish Lachwani

Ashlesha Shintre wrote:
On Wed, 2006-11-22 at 22:17 +0000, Ralf Baechle wrote:
On Wed, Nov 22, 2006 at 11:42:39AM -0800, Ashlesha Shintre wrote:

During boot up on the Encore M3 board (AU1500 MIPS) of the
kernel, the process stops after the NFS filesystem has been mounted,
memory freed  and spits out the following message:

request_module: runaway loop modprobe net-pf-1
The kernel tried to open UNIX domain socket but because support is not
compiled it will load the module instead.  Now, glibc-based programs
happen to try to connect to nscd via a UNIX domain socket on startup
and the whole show starts all over.  After a few iterations the kernel
gets tired of the whole game and prints this friendly message.

What does the net-pf-1 mean?
net-pf-1 is PF_UNIX, see the definitions in include/linux/socket.h.  So
you should set CONFIG_UNIX to y.

Thanks for your reply Ralf, but I dont see he CONFIG_UNIX option in my
Makefile, so I created one, but still get the same error!
is there anything else that i should try?

Thanks again,
Building it as a module won't work
as you just found :).


<Prev in Thread] Current Thread [Next in Thread>