[Top] [All Lists]

Re: "relocation truncated to fit: R_MIPS_CALL16"

To: zhuzhenhua <>
Subject: Re: "relocation truncated to fit: R_MIPS_CALL16"
From: Niklaus <>
Date: Mon, 24 Apr 2006 14:06:43 +0530
Cc: linux-mips <>
Domainkey-signature: a=rsa-sha1; q=dns; c=nofws; s=beta;; h=received:message-id:date:from:to:subject:cc:in-reply-to:mime-version:content-type:content-transfer-encoding:content-disposition:references; b=q9NpklqTYipwsmCmJ/PbYL3AYLNxk9q3CB8+Zh8D+0ksVpJ1PZnvzKoBVbDlPNN3gmCRHagAo/7RBlIZK5B7gXZBigw5aKLVydzrCqtrtFBPwOOxsLU/tY13eLtI/UMf9NFFvhlrrkKmB/rZ1ZtA0yHU7d/gRXRIDlBYL7IK6nM=
In-reply-to: <>
Original-recipient: rfc822;
References: <>
On 4/23/06, zhuzhenhua <> wrote:
> i want to write a mini bootloader for my board, so i need jump to c
> code from asm code
> but when i compile and ld, i get "relocation truncated to fit:
> R_MIPS_CALL16" messages for every function call..
I had this error sometime back.
I increased the size of ROM0 and RAM0 in linker script which was used by ld.

I initially had problem using mips-linux-gcc(only for linux userspace
application) toolchain, when i used the target mips-elf-gcc(this one
should be used) i got around it.

> i have try the mips_4KCle-gcc(worked for u-boot),
> mips_fp_le-gcc(worked for mvita linux), and also a
> mipsel-linux-gcc(worked for my linux 2.6 kernel), but they all failed,
> even i add -G0 to gcc.
> and i only compile success by using mips-elf-gcc under cygwin.
> does it be caused by binutils version? or gcc compile CFLAGS?
> thanks for any hints
> Best Regards
> Zhuzhenhua

<Prev in Thread] Current Thread [Next in Thread>