[Top] [All Lists]

Au1200 MAE drivers

Subject: Au1200 MAE drivers
From: "Eric Gaulin" <>
Date: Fri, 21 Apr 2006 09:15:54 -0400
Domainkey-signature: a=rsa-sha1; q=dns; c=nofws; s=beta;; h=received:message-id:date:from:to:subject:mime-version:content-type; b=JJZNwkJjmSYVpgP1rCAY5r+Q6oeAnUeHrHvMzMHURPT2mXxo29LjkrV9AvmO5HHlQXCF/f626n13GL3GN9sR1Gj1mwp736xasT0rznJ/UkSQr4ZiPIW+RI8ypWjaphAHKQwLvRHMdQWY72Txcev3sHaIHX8Ynr+8NIKKnWik1rI=
Original-recipient: rfc822;

We have the DbAu1200 evaluation board from AMD.

With the help of the buildroot utility  project  we have  successfully:   

- crosscompiled / booted the Linux 2.6.11-r00058 kernel sources (from AMD which include patch for the db1200)
- crosscompiled / booted the Linux 2.6.16 kernel (vanilla sources)

Building the AMD Alchemy Au1200 MAE drivers and tools was also possible with the same tools but when we want to start the maiplayer front end for the mae driver we get this message:

* The source tar.gz used was: amdms2-1.0-01.02.75-src.tar.gz

MAIplayer - console-based player using MAIengine
MAIEngine Version 3.4     BUILD V.00010275  Date 06040501
MAIEngine result: 0x00000000 Success
Engine Command ('help' for help):
open "10.mp4"
MAIEngine result: 0x00000000 Success
Engine Command ('help' for help):

Trying to free free IRQ9
Trying to free free IRQ4
Trying to free free IRQ31
Trying to free free IRQ1
Trying to free free IRQ30
open_mae_driver() version (structure size) mismatch: driver=0 interface=200

According to this document 40351a_dbau1200_openemb_appnote.pdf (from AMD's developer's website), It is possible to build en entire Linux system for this platform using the OpenEmbedded project

AMD Have on their developer's website a tool kit for the Au1200/DbAu1200 for OpenEmbedded which is mainly a set of patches and config files for their specifics hardware, processor and piece of software like mae drivers and a patched 2.6.11 Linux kernel sources for au1200. (the kit used was: au1200-dev-kit_v1.0-r3.tar.gz)

The catch is that OpenEmbedded is a very active project and a daily snapshot of the development archive is available and the older snapshots are kept for about 30 days. The problem is the AMD's OpenEmpedded toolkit was based on a quite old snapshot (oe_20050727083537.tgz) July 27th 2005 and most of the patches doesn't apply anymore to the current OE snapshots.

We managed to manually  patch what is blocking the compilation of openembedded by disabling things that aren't important four our needs and finally we where able to boot this openembedded linux for db1200.

And we had the same poor results for the MAE Driver as we had with buildroot earlier.  (We built OE with either glibc or uclibc)

We have chosen to use OpenEmbedded for theses reasons;
  1. After requesting some "support" from AMD about how they have managed to compile the MAE, we where told that they use MontaVista and OpenEmbedded.
  2. AMD provide a precompiled demo image based on it.
  3. It is open.
  4. MontaVista preview toolkit (3.1) do not support Db1200.
* MontaVista claim that they support Db1200 with their 4.x pro version but having tried 2 crosscompilation tool chain with the same results, we don't want to waste money on something that would give us the same result.

I am desperately seeking help before diving into debugging this MAE thing (wich is supposed to work)


Eric Gaulin

<Prev in Thread] Current Thread [Next in Thread>
  • Au1200 MAE drivers, Eric Gaulin <=