[Top] [All Lists]

"Hw. address read/write mismap 0" or RTL8019 ethernet in linux

To: linux-mips <>
Subject: "Hw. address read/write mismap 0" or RTL8019 ethernet in linux
From: zhuzhenhua <>
Date: Tue, 21 Feb 2006 13:33:03 +0800
Domainkey-signature: a=rsa-sha1; q=dns; c=nofws; s=beta;; h=received:message-id:date:from:to:subject:mime-version:content-type:content-transfer-encoding:content-disposition; b=Wu0h4EB13IToimQz0+FfJZcoDbDBZdPqXTB0qifOrr3+SV++sOu4OUHsZyZsbRUjaKUewqKVWYCToTLUFxdjNsQPqVurZtCr7g4i7Zm6xs4ORfXBUjca6tjg3Jy3UC1WxqQRqIAREPKhYqOeD4Vyg1Hdnq57vEgt0FasiYEHlWU=
Original-recipient: rfc822;
i want to add a RTL8019 ethernet driver for my board, when i run the
linux, at the init of ethernet, it get

eth0: trigger_send() called with the transmitter busy.
.<6>NETDEV WATCHDOG: eth0: transmit timed out
Hw. address read/write mismap 0
Hw. address read/write mismap 1
Hw. address read/write mismap 2
Hw. address read/write mismap 3
Hw. address read/write mismap 4
Hw. address read/write mismap 5

then i check the code and find it's in 8390.c, caused by uncorrect
write of MAC addr, and now i repalce all the inb,outb,inb_p, outb_p
with get_reg and put_reg in the follow:

static unsigned char get_reg (unsigned int regno)
        return (*(volatile unsigned char *) regno);

static void put_reg (unsigned int regno, unsigned char val)
        *(volatile unsigned char *) regno = val;

 it can run over t he ethernet init, and it also can mount nfs root
fs, it can ping and responding to ping, and also can do copy,delete in
the nfs root.
 but when i run  application in nfs root, it get message as follow,
and hang on it
"nfs: server not responding, still trying"

does someone have any idea of this situation?

thanks for any hints

Best regards


<Prev in Thread] Current Thread [Next in Thread>