[Top] [All Lists]

Re: SGI IP28 Kernels... anyone had any luck lately?

Subject: Re: SGI IP28 Kernels... anyone had any luck lately?
From: Stuart Longland <>
Date: Sat, 10 Dec 2005 21:50:36 +1000
In-reply-to: <Pine.LNX.4.21.0512091803080.1379-100000@Opal.Peter>
Openpgp: id=63264AB9; url=
Organization: Gentoo Foundation
Original-recipient: rfc822;
References: <Pine.LNX.4.21.0512091803080.1379-100000@Opal.Peter>
User-agent: Mozilla Thunderbird 1.0.7 (X11/20051029)

peter fuerst wrote:
> sorry, obviously forgot to "tar" with the "-h" option.  The kernel patch-set
> is now repackaged with README and .config (same location).  I wonder, why no
> one noticed their missing since Oct 17...

Heh, I wondered that myself... Anyways, it's fixed now. :-)

> For exactness' sake: the patches are based on 
> linux-2.6.14-rc2-mipscvs-20050925
> Maybe .config will enable compiling, the error-messages seem to point
> to a misconfiguration, since the compiler didn't touch any of the patched
> files yet.

I did try using the linux-2.6.14-rc2 tag out of git (repository as of
20051204; I didn't bother going to bleeding edge), but found I got the
same errors.

The problems disappeared, however, when I tried 2.6.14-rc1... this seems
to work just fine.

> indigo ~ # uname -a
> Linux indigo 2.6.14-rc1-ip28 #4 Sat Dec 10 18:26:46 EST 2005 mips64 R10000 
> V2.5  FPU V0.0 SGI Indigo2 GNU/Linux
> indigo ~ # uptime
>  21:49:13 up  3:21,  3 users,  load average: 2.63, 1.38, 0.71

The only glitch I've hit so far, is that booting via the local
framebuffer (okay, I know it isn't a true "framebuffer") causes a fatal
oops.  However, if I specify console=ttyS0,9600, I see a flashing cursor
on the framebuffer, and the bootup proceeds to completion on the serial
console.  Which is good news... it wasn't long ago when I recall merely
sneezing in front of the machine was enough to send it spiralling into a
fatal oops.

> There's still a problem with the Xserver: often, when starting up the Xserver
> first after a cold boot, it likes to hang (in a loop, waiting for "dmabusy"
> to settle down, either in the kernel-driver or the Xserver itself, when
> re-mmapping the dma-buffer). Usually, after a reset the Xserver works okay.
> I couldn't find a solution for this yet, but otherwise (;-) i easily (can) use
> the machine for regular work (no more hangs after the Xserver started up 
> once).

As I say... this Linux port has really bounded ahead in the time I've
had this IP28 of mine... considering the hardware issues that have to be
worked around. :-)

X is my next step... for the moment though, I'm happy to be able to use
a real monitor, and not a serial console. :-)
Stuart Longland (aka Redhatter)              .'''.
Gentoo Linux/MIPS Cobalt and Docs Developer  '.'` :
. . . . . . . . . . . . . . . . . . . . . .   .'.'             :.'

Attachment: signature.asc
Description: OpenPGP digital signature

<Prev in Thread] Current Thread [Next in Thread>