[Top] [All Lists]

Re: SGI IP28 Kernels... anyone had any luck lately?

Subject: Re: SGI IP28 Kernels... anyone had any luck lately?
From: peter fuerst <>
Date: Fri, 9 Dec 2005 18:22:14 +0100 (CET)
Cc: Stuart Longland <>
In-reply-to: <>
Original-recipient: rfc822;
Resent-date: Fri, 9 Dec 2005 19:21:52 +0100 (CET)
Resent-from: peter fuerst <>
Resent-message-id: <Pine.LNX.4.21.0512091921520.1600@Opal.Peter>
Resent-subject: Re: SGI IP28 Kernels... anyone had any luck lately?
Resent-to: Stuart Longland <>,

Hi all,

sorry, obviously forgot to "tar" with the "-h" option.  The kernel patch-set
is now repackaged with README and .config (same location).  I wonder, why no
one noticed their missing since Oct 17...
For exactness' sake: the patches are based on linux-2.6.14-rc2-mipscvs-20050925
Maybe .config will enable compiling, the error-messages seem to point
to a misconfiguration, since the compiler didn't touch any of the patched
files yet.

There's still a problem with the Xserver: often, when starting up the Xserver
first after a cold boot, it likes to hang (in a loop, waiting for "dmabusy"
to settle down, either in the kernel-driver or the Xserver itself, when
re-mmapping the dma-buffer). Usually, after a reset the Xserver works okay.
I couldn't find a solution for this yet, but otherwise (;-) i easily (can) use
the machine for regular work (no more hangs after the Xserver started up once).

kind regards


On Sat, 10 Dec 2005, Stuart Longland wrote:

> Date: Sat, 10 Dec 2005 00:39:40 +1000
> From: Stuart Longland <>
> Reply-To:
> To:
> Subject: SGI IP28 Kernels... anyone had any luck lately?
> Hi all,
>       I'm not sure what's causing this error, could very well be PEBKAC, but
> anyways.
>       I've been striking issues getting kernels for my IP28 to compile.  So
> far, I've tried both the 2.6.14 and 2.6.14-rc2 tags, the IP28 patches[1]
> apply successfully, but the subsequent compile fails with these
> messages:
>       Incidentally, the tarball you download containing the patches,
> apparently has a README and .config file included.  Well, there's
> symlinks to the files, but it seems the actual files themselves got
> missed in the archive.  I used the /proc/config.gz from my currently
> running kernel (2.6.12-rc2, also works with
>       I was hoping to try out Impact support, in console and X, as well as
> HAL2 support (which was b0rked last time I tried it).
>       Has anyone had any luck, and if so, any ideas what I'm doing wrong?
> Regards,
> -- 
> Stuart Longland (aka Redhatter)              .'''.
> Gentoo Linux/MIPS Cobalt and Docs Developer  '.'` :
> . . . . . . . . . . . . . . . . . . . . . .   .'.'
>             :.'
> 1.

<Prev in Thread] Current Thread [Next in Thread>