[Top] [All Lists]

Re: AMD Au1100 problems (USB & Ethernet)

Subject: Re: AMD Au1100 problems (USB & Ethernet)
From: Sylvain Munaut <>
Date: Sat, 06 Aug 2005 12:42:50 +0200
In-reply-to: <1123276474.23193.6.camel@localhost.localdomain>
Original-recipient: rfc822;
References: <> <1123271252.19992.189.camel@localhost.localdomain> <> <1123272640.19992.199.camel@localhost.localdomain> <> <1123276474.23193.6.camel@localhost.localdomain>
User-agent: Mozilla Thunderbird 1.0.2 (X11/20050610)
Pete Popov wrote:

>>The RX errors are reported as "rx miss" (RX_MISSED_FRAME set) which is
>>described as "Internal FIFO overrun". Maybe those are just OK and it's
>>just that it can't wistand full 100Mbps (the module is connected on a
>>10/100/1000 switch and the server is gigabit).
> No, I don't think that's normal.

Maybe it has something to do with initialisation that I don't do
properly. The bootloader is uMon, not YaMon so maybe something is
execpted to be setup that I don't know of.

>>The TX errors are time-out, how can I find more details about that ?
> If possible, eliminate the gig switch by replacing it with a small
> 10/100 switch. If the problems go away, then that's a big clue.

I don't habe a 10/100 switch but I tried on a 10/100 Hub and the results
are quite the same. I just have a few "rx runt" error more that are due
to the hub.

> Take a look at what the bcm phy is auto-negotiating and make sure it
> matches what the switch thinks it has negotiated. Although, the tx
> timeouts should have nothing to do with mismatched auto negotiation...
> but I see there are a bunch of "carrier" errors.

Phy reports 100Mbps half duplex with the hub and 100Mbps full duplex
with the switch, which looks correct.

btw, It seems that after a timeout error, the au1000_timer isn't
restored correctly ( I put a printk in it and before the errors, it
prints every sec, and never after ).

> You of course tried a different cable, just in case?

Sure, with 3 differents cables in fact.


<Prev in Thread] Current Thread [Next in Thread>