[Top] [All Lists]

Re: booting error on db1550 using linux 2.6.12 from

To: Alan Cox <>
Subject: Re: booting error on db1550 using linux 2.6.12 from
From: rolf liu <>
Date: Fri, 8 Jul 2005 12:27:06 -0700
Cc:, "" <>
Domainkey-signature: a=rsa-sha1; q=dns; c=nofws; s=beta;; h=received:message-id:date:from:reply-to:to:subject:cc:in-reply-to:mime-version:content-type:content-transfer-encoding:content-disposition:references; b=jr+T7JPcqCgiNll7FLSWKAZrDl4je8EawpnlCm345h+q6a1Pn8jyyzneFpStn0G2cKg6oRX3+18RHLqntZjXg1aiKW7BPR8QQP6Ca+HQ3rI7z5s3KmI49kcplfMMk7MJAZG+SWIDq1YxM5yLYz79b658mGe58aPwaqNsRopwKOc=
In-reply-to: <1120776436.317.57.camel@localhost.localdomain>
Original-recipient: rfc822;
References: <> <1120253048.5987.16.camel@localhost.localdomain> <> <1120257851.5987.37.camel@localhost.localdomain> <> <1120756200.317.14.camel@localhost.localdomain> <> <1120776436.317.57.camel@localhost.localdomain>
Reply-to: rolf liu <>

I tried ide=nodma as boot option. It doesn't work either. It stops at
the same place.

Then I used pci_write_config_byte(dev, 0x5b, 0x21); It works and can
boot with the hard disk.  I also tried to force the 372n timing with
the linux-mips cvs head, It also works fine.

I know using PCI Clock as the only timing could have some speed
problems. And forcing 372n timing is like a dirty hack.  Your
suggestion is really appreciated.


On 7/7/05, Alan Cox <> wrote:
> On Iau, 2005-07-07 at 19:42, rolf liu wrote:
> > Alan,
> > Tried your patch on db1550 and linux 2.6.12. It still doesn't work.
> > During the boot-up, the kernel will hang up right after it prints out:
> >
> > >>hdg: max request size: 128 KiB
> > Any suggestion?
> Its got started if it gets that far because the LBA48 status has been
> checked. What occurs if you boot with ide=nodma ?

<Prev in Thread] Current Thread [Next in Thread>