[Top] [All Lists]

Re: Seg fault when compiled with -mabi=64 and -lpthread

To: Daniel Jacobowitz <>
Subject: Re: Seg fault when compiled with -mabi=64 and -lpthread
From: "Maciej W. Rozycki" <>
Date: Fri, 1 Jul 2005 09:49:39 +0100 (BST)
Cc: "Stephen P. Becker" <>, Ralf Baechle <>, Bryan Althouse <>, "'Linux/MIPS Development'" <>
In-reply-to: <>
Original-recipient: rfc822;
References: <> <> <> <> <>
On Thu, 30 Jun 2005, Daniel Jacobowitz wrote:

> > Hmm, well with respect to my problem, I'm using a pretty recent
> > toolchain, with gcc 3.4.4, binutils-2.16.1, glibc-2.3.5, and headers
> > from a linux-mips 2.6.11 snapshot.  Interestingly, I tried to reproduce
> > Bryan's segfault, but could not.  That code ran without error when I
> > linked with libpthread.  Any thoughts?
> I don't think glibc 2.3.5 worked for mips64.  But I haven't checked it
> in a long time.  Try CVS HEAD of glibc instead.

 Well, I tried a few trivial programs that use libpthread in my (n)64 
environment, which is based on 2.3.5, and they worked just fine.  They 
could have bin as simple as `ls', but as I have seen in the original 
report you do not have to make extensive use of the library to trigger 
problematic behaviour.

 Though it can be related to patches I have applied, me having built glibc 
with GCC 4.0.0 or perhaps it only happens for BE...

> Other than that, you're on your own - building glibc is extremely error
> prone.

 And you may need external patches as glibc is (effectively) not 


<Prev in Thread] Current Thread [Next in Thread>