[Top] [All Lists]

Re: Seg fault when compiled with -mabi=64 and -lpthread

To: "Stephen P. Becker" <>
Subject: Re: Seg fault when compiled with -mabi=64 and -lpthread
From: Daniel Jacobowitz <>
Date: Thu, 30 Jun 2005 23:51:05 -0400
Cc: Ralf Baechle <>, Bryan Althouse <>, 'Linux/MIPS Development' <>
In-reply-to: <>
Original-recipient: rfc822;
References: <> <> <> <>
User-agent: Mutt/1.5.8i
On Thu, Jun 30, 2005 at 06:09:09PM -0400, Stephen P. Becker wrote:
> > Bryan seems to be using the original Red Hat gnupro 64-bit toolchain. 
> > I don't know how well that works nowadays; but current CVS versions do
> > work, or did when I last tested (a month or two ago).
> > 
> Hmm, well with respect to my problem, I'm using a pretty recent
> toolchain, with gcc 3.4.4, binutils-2.16.1, glibc-2.3.5, and headers
> from a linux-mips 2.6.11 snapshot.  Interestingly, I tried to reproduce
> Bryan's segfault, but could not.  That code ran without error when I
> linked with libpthread.  Any thoughts?

I don't think glibc 2.3.5 worked for mips64.  But I haven't checked it
in a long time.  Try CVS HEAD of glibc instead.

Other than that, you're on your own - building glibc is extremely error

Daniel Jacobowitz
CodeSourcery, LLC

<Prev in Thread] Current Thread [Next in Thread>