[Top] [All Lists]

Re: 2.6 on IP22 (Indy)

To: Markus Dahms <>
Subject: Re: 2.6 on IP22 (Indy)
From: "Stephen P. Becker" <>
Date: Tue, 28 Jun 2005 08:23:45 -0400
In-reply-to: <>
Original-recipient: rfc822;
References: <> <> <> <> <> <> <>
User-agent: Mozilla Thunderbird 1.0.2 (X11/20050625)
> [R4600 tlbex.c patch]
> This doesn't seem to be enough. The patch applies almost cleanly on
> current CVS (offset -1 line), but the resulting kernel (I tried 64
> and 32-bit) still stops after "INIT: ...".

This might be a good time to mention that cvs HEAD seems to have serious
problems with 64-bit ip22 kernels (at least on r5000 systems...I don't
have a working r4x00 box to test with), and it may be contributing to
your problems.  Basically, numerous messages about vmalloc dump to the
kernel log while doing a number of things disk related:

allocation failed: out of vmalloc space - use vmalloc=<size> to increase

Symptons include ricerfs partitions not being able to mount (ext3 seems
to work, but still triggers the vmalloc error message), swapon failing
to turn the swap partition on, dd having major problems when dumping
large blocks, etc.  The initial probing of the scsi controller at boot
time also triggers the message.

I haven't tried a 32-bit kernel since 2.6.12_rc2 or so, however when I
did, everything seemed to work just fine, while a 64-bit kernel compiled
from the same checkout had the same problems I mention above.  At one
point I was trying to work out when this was introduced, and I *think*
it was the initial 2.6.11 merge, but I would have to double check that.
 I've been running a 64-bit 2.6.10 checkout since the beginning of the
year on that box, and the machine has been very stable.


<Prev in Thread] Current Thread [Next in Thread>