[Top] [All Lists]

Re: 64 bit kernel for BCM1250

To: "Maciej W. Rozycki" <>
Subject: Re: 64 bit kernel for BCM1250
From: Michael Belamina <>
Date: Tue, 17 May 2005 12:52:32 -0700 (PDT)
Comment: DomainKeys? See
Domainkey-signature: a=rsa-sha1; q=dns; c=nofws; s=s1024;; b=LBysdeL0ujsPg5Wsf/Roll0muB5wnfFILoCtMcjgfEEayNMu73JTzdKqSx+nJBAYRxGk87xkNaeUSTl68o1aVHdGBeoQGVeYeuqGaPl+II7lnM4vD/sbz+FGO8Qv4Yd37PpxqTckgEdXSvMay6Lyn0k3dBIKRnEZ3Zgj9NpSkSA= ;
In-reply-to: 6667
Original-recipient: rfc822;

  Thanks for your reply.
  I tried using the resulted vmlinux.32 and got the
same result. 

  After looking into it, I found out that t0 is loaded
with 0x0 while it should load _edata value which
should be 0xffffffff80310000 (according to the   in the 32 bit version (which I build
using a different toolchain), edata is loaded to t0
register as it should.

It looks to me like it is a toolchain problem. 

1. where can I download a pre built, prooven working
64 bit toolchain?

2. Is there anything else that can cause this problem?


--- "Maciej W. Rozycki" <> wrote:
> On Tue, 17 May 2005, Michael Belamina wrote:
> >   I have built a 64 bit kernel for BCM1250.
> >   When the kernel is loaded and control is passed
> to
> > kernel_entry there is an exception:
> > 
> > CFE> boot -elf LinuxServer:vmlinux.64
> [...]
>  I'm assuming vmlinux.64 is a 64-bit ELF file.  If
> so, then, well, 
> depending on the version of CFE you have, this may
> or may not work.  The 
> workaround is to always use 32-bit ELF files.  You
> should get one after 
> your Linux build -- if not (which may depend on how
> you do builds), then 
> try `make vmlinux.32' and use the result.
>   Maciej

Do You Yahoo!?
Tired of spam?  Yahoo! Mail has the best spam protection around 

<Prev in Thread] Current Thread [Next in Thread>