[Top] [All Lists]

Mips 4KEC

To: "'Linux/MIPS Development'" <>
Subject: Mips 4KEC
From: "Mile Davidovic" <>
Date: Wed, 11 May 2005 16:20:53 +0200
Organization: MicronasNIT
Original-recipient: rfc822;
Reply-to: <>
Thread-index: AcVWNKOCiTGfbgnLQ5CxCzsEl5x71g==
Hello all

I tried to port linux 2.6.11-mipscvs-20050313 on MIPS 4KEC processor.

But I faced with some problems.

1. I have question regarding toolchain, I use toolchain which came from
uclibc buildroot
application. Gcc version is 3.4.2, is it ok?

2. I tried to use sde-lite 5.03 toolchain but this toolchain (sde-gcc)
failed to build kernel. 
    Please any comments regarding this issue? 

3. I tried to remove optimization from kernel: 
                ifdef CONFIG_CC_OPTIMIZE_FOR_SIZE
                CFLAGS          += -Os
                #CFLAGS         += -O2
but kernel failed to compile with next messages:
        init/built-in.o(.init.text+0x216c): In function
        init/do_mounts_rd.c:92: undefined reference to `ntohl'
        kernel/built-in.o(.text+0xf6f4): In function `put_files_struct':
        include/asm/system.h:270: undefined reference to
        kernel/built-in.o(.text+0xf708):include/asm/system.h:273: undefined
reference to `__xchg_called_with_bad_pointer'
        kernel/built-in.o(.text+0x13264): In function `wait_task_zombie':
        include/asm/system.h:270: undefined reference to
        kernel/built-in.o(.text+0x13278):include/asm/system.h:273: undefined
reference to `__xchg_called_with_bad_pointer'
I tried with googling but it seems that nobody faced similar problem? Is it
possible to buidl kernel without optimization?

Best regards Mile

<Prev in Thread] Current Thread [Next in Thread>