[Top] [All Lists]

Re: your mail (yosemite + 2.6.x issues)

To: Bryan Althouse <>
Subject: Re: your mail (yosemite + 2.6.x issues)
From: Manish Lachwani <>
Date: Fri, 29 Apr 2005 09:08:39 -0700
Cc: 'Ralf Baechle' <>,
In-reply-to: <>
Original-recipient: rfc822;
References: <>
User-agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4.2) Gecko/20040308
Do you load the kernel first and then do a "go"? If you load the kernel first using the "load" command, then you should come back to the PMON prompt where you can type a "go". I was not clear about it from your email below.

Manish Lachwani

Bryan Althouse wrote:

Thanks Ralf, now I can compile the kernel.  But, I don't get any serial
console output when I try to boot it.  Actually, I get a single line that
looks like this:

Loading file: tftp:// (elf)
0x80100000/2288188 + 0x8032ea3c/111372(z) + 4125 syms|

I have found PMC's "yosemite_defconfig" file and I am using it as the
".config". I have tried using CONFIG_PMC_INTERNAL_UART=y and I have also
tried commenting it out.  Either way, I get no console output.

Thanks for the help!

-----Original Message-----
From: Ralf Baechle [] Sent: Friday, April 29, 2005 7:03 AM
To: Bryan Althouse
Subject: Re: your mail

On Thu, Apr 28, 2005 at 03:15:49PM -0400, Bryan Althouse wrote:

I would like to use a 2.6.x kernel with my Yosemite/HalfDome board.
Somehow, I am unable to compile the kernel.  I have tried the 2.6.10
trees from and also the latest 2.6.12 snapshot from
linux-mips.  I am using the 3.3.x cross compile tools from .  The 2.4.x kernels from PMC compile fine.

In the case of 2.6.10 from, my error looks like:
      Make[3]: *** [drivers/char/agp/backend.o] Error 1

Configuring AGP support for a MIPS kernel is obviously nonsense.  Disable

In the case of 2.6.12 from linux-mips, my error looks like:
        drivers/net/titan_ge.c1950: error: 'titan_device_remove"  undeclared
here (not in a function)

Whoops, a bug.  The function indeed doesn't exist even though it should,
will fix that.  You will hit this bug only if compiling the titan driver
as a module, so workaround set CONFIG_TITAN_GE=y.  Which for the typical
titan-based device seems to be the preferable choice anyway.


<Prev in Thread] Current Thread [Next in Thread>