[Top] [All Lists]

Re: GD Library on MIPS Processor

Subject: Re: GD Library on MIPS Processor
From: Ulrich Eckhardt <>
Date: Fri, 29 Apr 2005 12:09:33 +0200
In-reply-to: <005201c54c93$64a5fb30$>
Organization: Sator Laser GmbH
Original-recipient: rfc822;
References: <015301c54c01$9b8e4e00$> <> <005201c54c93$64a5fb30$>
User-agent: KMail/1.7.2
Inpreet Singh wrote:
> I want to use gd library on MIPS processor. Due to limited memory on mips,
> I cannot compile gd library on it. So I need to compile it on linux intel
> processor and transfer executable files on MIPS. I have compiled gd library
> on intel linux and successfully tested it. But how to compile gd library
> for MIPS processor? I tried to configure it with these commands
> 1. ./configure --host=mips-unknown-linux-gnu
> 2. ./configure --host=mips-linux
> 3. ./configure --host=mips-linux --build=mips-linux --target=mips-linux
> 4. ./configure --host=mips-linux --build=mips-linux

If you're building on Linux/x86, using '--build=mips-linux' is obviously 
completely bogus.

> but none of them had worked for me. Whenever after compiling I place my
> executables and try to test them, they fails to return results.

This could have another reason, see below...

> gd library after configure command dynamically generates Makefile. Now
> method to test your application which you have to write in a c program is
> so make this program with this Makefile. Lets suppose you make an example
> and name it as test.c so what you have to do is enter test.c in this
> dynamically generated Makefile and write command make test this will
> outputs in test executable file. Which we can run using command ./test on
> our command prompt.
> Whenever I perform this task it always shows errors:
> **************************************************************
> /launchpad # ./gddemo
> ./gddemo: 1: Syntax error: "(" unexpected

If this program gives this message, then it is running. Why it gives it is a 
totally unrelated thing. 

 Now, what could also be the case is that you didn't grab the executable but a 
script. Autotools usually generate a script in the builddir that setup the 
runtime linker so it finds the (not yet installed) libraries and then calls 
the executable inside the hidden .lib directory.

If this all fails, create a minimal hello-world and compile it with
'mips-linux-gcc -Wall -o hw hello.c' and try that on the host machine.


<Prev in Thread] Current Thread [Next in Thread>