[Top] [All Lists]

Re: GD Library on MIPS Processor

To: Stuart Longland <>
Subject: Re: GD Library on MIPS Processor
From: Inpreet Singh <>
Date: Fri, 29 Apr 2005 13:43:58 +0530
Original-recipient: rfc822;
References: <015301c54c01$9b8e4e00$> <>
I want to use gd library on MIPS processor. Due to limited memory on mips, I
cannot compile gd library on it. So I need to compile it on linux intel
processor and transfer executable files on MIPS. I have compiled gd library
on intel linux and successfully tested it. But how to compile gd library for
MIPS processor? I tried to configure it with these commands
1. ./configure --host=mips-unknown-linux-gnu
2. ./configure --host=mips-linux
3. ./configure --host=mips-linux --build=mips-linux --target=mips-linux
4. ./configure --host=mips-linux --build=mips-linux

but none of them had worked for me. Whenever after compiling I place my
executables and try to test them, they fails to return results.

gd library after configure command dynamically generates Makefile. Now
method to test your application which you have to write in a c program is so
make this program with this Makefile. Lets suppose you make an example and
name it as test.c so what you have to do is enter test.c in this dynamically
generated Makefile and write command make test this will outputs in test
executable file. Which we can run using command ./test on our command

Whenever I perform this task it always shows errors:
/launchpad # ./gddemo
./gddemo: 1: Syntax error: "(" unexpected
eval: 1: gcc: not found
I have used Source-Navigator and tried to compile my project using mips
compiling option but doesn't workout. So please help me. please tell me what
is best procedure to compile and test gd library on MIPS processor when due
to memory limitation I cannot compile project on MIPS itself, on my MIPS
processor I have installed linux with very limited command set.
Inpreet Singh

<Prev in Thread] Current Thread [Next in Thread>