[Top] [All Lists]

Re: GD Library on MIPS Processor

To: "Inpreet Singh" <>
Subject: Re: GD Library on MIPS Processor
From: "Stuart Longland" <>
Date: Fri, 29 Apr 2005 06:51:02 -0000 (Local time zone must be set--see zic manual page)
Importance: Normal
In-reply-to: <015301c54c01$9b8e4e00$>
Original-recipient: rfc822;
References: <015301c54c01$9b8e4e00$>
User-agent: SquirrelMail/1.4.2
Hash: SHA1

Okay, before I start... can you please turn off HTML message composition?
Some users here don't take kindly to HTML email. ;-)

> Sir I am using gd library on Linux intel processor sucessfully but now I
> want to do same on MIPS. I don't know to how install, configure and test
> gd library on MIPS. Sir please give me some clue or link to study for
> the same.
> I tried to configure gd library compilation using following command from
> linux intel processor:
> ./configure --host=mips

Try ./configure --host=mips-unknown-linux-gnu (or mips-unknown-linux-uclibc if
you use µClibc).  Setting --build and --target may help too.

> and it makes Makefile with some differences
> ***************************************************
> host_triplet = mips-unknown-elf
> host = mips-unknown-elf
> host_alias = mips
> host_cpu = mips
> ***************************************************
> Now I tried to build a example using this Makefile "make gddemo". What I
> expect that it will create gddemo binary that will output in correctly
> on MIPS processor. But when I run this binary on MIPS it is showing
> errors.
> **************************************************************
> /launchpad # ./gddemo
> ./gddemo: 1: Syntax error: "(" unexpected
> **************************************************************

I'm not sure what's going on there... but I'd presume it's related to the
wrong `host` option being set.

Also, make sure you run the compiled binaries on the MIPS machine... they
won't work on x86 (you'll get a "cannot execute binary file" error message).

> Also I have downloaded debian packages for gd library on MIPS processor
> but don't know how to install them. I tried dpkg command but it shows no
> such command. So sir please help me out.
> So please help me how should I proceed.

That's odd.  Do you have Debian installed correctly on the MIPS machine?  What
version/distribution did you install?

- --
| Stuart Longland -oOo- |
| Atomic Linux Project     -oOo- |
| - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - |
| I haven't lost my mind - it's backed up on a tape somewhere |

Version: GnuPG v1.2.6 (GNU/Linux)


<Prev in Thread] Current Thread [Next in Thread>