[Top] [All Lists]

troubles mmaping PCI device on Au1550

Subject: troubles mmaping PCI device on Au1550
From: Clem Taylor <>
Date: Sun, 10 Apr 2005 18:16:17 -0400
Domainkey-signature: a=rsa-sha1; q=dns; c=nofws; s=beta;; h=received:message-id:date:from:reply-to:to:subject:mime-version:content-type:content-transfer-encoding; b=Jb76gL8cgOFLhEQdkLO4JehHLq5lHxPmanN5japzh7zyTlJ60EoSpHjSeVrKkq+YxTaJ7iyavk1bHZytnY9RxVIdofkz1kmO+piiV9fghYBejp3TqBJjecLlfl465rD59jhDv9w3+UDDM+2H9CFlIPKmy5HpOtGXTl8envK7njo=
Original-recipient: rfc822;
Reply-to: Clem Taylor <>
I'm working on a Au1550 driver for a PCI based co-processor. The
processor exports a 4Mbyte BAR that I want to mmap() into user space.
From inside the driver I can read and write to the BAR using an
address from ioremap_nocache(). I can read location with known values
and get back the expected data and with JTAG on the co-processor I saw
that data written from the 1550 really makes it into the PCI device.
From userspace with the llseek/read interface I can read the data well
known data and the data written by the driver.

However, I'm not having any luck getting mmap() to work. I must just
be mapping the wrong address... I tried a bunch of different
combinations of addresses, but so far I haven't had any luck getting
the mmap() to work.

The mmap() handler calls remap_pfn_range with a physical address
returned from pci_resource_start().

My driver code has something like:
remap_pfn_range ( vma, vma->vm_start,
     ( pci_resource_start ( pdev, BAR ) >> PAGE_SHIFT ) + vma->pgoff,
     vma->vm_end - vma->vm_start, vma->vm_page_prot );

vma->pgoff is zero, so this should map starting at the beginning of
the BAR. From user space, the data at the mmap()ed address isn't what
I was expecting.

For a sanity check, I tried using /dev/mem to mmap the PCI address as
returned by lspci. This seems to return similar, but not identical
data as my device driver. But it isn't what I was expecting.

I tried a similar test using /dev/mem and the address the linear
framebuffer on my desktop machine (as returned by lspci). The mapped
data matches the pixels on the first line (as reported by xmag).

Has anyone tried something like this on the Alchemy processors with a
recent kernel?

                          Many thanks,
                          Clem Taylor

<Prev in Thread] Current Thread [Next in Thread>