[Top] [All Lists]

Re: gdb backtrace with core files

To: Daniel Jacobowitz <>,
Subject: Re: gdb backtrace with core files
From: Brian Kuschak <>
Date: Thu, 7 Apr 2005 13:43:29 -0700 (PDT)
Comment: DomainKeys? See
Domainkey-signature: a=rsa-sha1; q=dns; c=nofws; s=s1024;; b=q6JxWqdT3s6sZ1pKsID379kO74F+SYB+HjcYz34S/IZq7z/pDIDdKVovSXTcLg+SMsXRtIJ+KHPlpu4zQyY6UBNItGxsuUNNd4V3sSPLCkD5cF8VcIN5u+4NiSLX2e96a8OQQ78+2ny3Bh0JVkD4YHqd3NZAWwSiN7FB0MX2XuQ= ;
In-reply-to: 6667
Original-recipient: rfc822;
> > OK, tried again with version (GNU gdb
> >  Same result.
> > 
> > I'm running gdb on x86 host, debugging a binary
> for a
> > MIPS target.  I configured gdb as
> > ./configure --target mipsel-linux-gnu
> --enable-shared
> > --enable-threads 
> > 
> > Perhaps gdb isn't getting the right kernel headers
> > when built?  I added the configure options
> > --includedir and --oldincludedir to point to my
> > linux-mips kernel tree, but that didn't help
> either.  
> It does not use the kernel headers to work out the
> layout.  Are you
> using a current kernel?  I tested core dump support
> only a couple weeks
> ago.

I'm using a 2.4.25 vendor-patched kernel from
Broadcom.  I can poke around and compare the
core-dumping code to the latest mips-linux tree to see
if anything is different.


Do you Yahoo!? 
Yahoo! Small Business - Try our new resources site! 

<Prev in Thread] Current Thread [Next in Thread>