[Top] [All Lists]

Re: Netbooting CoLo on the Cobalt RaQ1

Subject: Re: Netbooting CoLo on the Cobalt RaQ1
From: Stuart Longland <>
Date: Sun, 20 Mar 2005 00:30:31 +1000
In-reply-to: <>
Original-recipient: rfc822;
References: <> <>
User-agent: Mozilla Thunderbird 1.0 (X11/20041206)
Martin Michlmayr wrote:
* Stuart Longland <> [2005-03-18 23:20]:

        It appears the RaQ1 is a special case, and does not look there to
download its kernel.  Does anyone know exactly where these boxes look
for the kernel image when netbooting?  That way, I can ammend[1] the
handbook with the new details.

Possibly vmlinux_RAQ.gz.  In Debian, we have a file called vmlinux.gz
and the symlinks vmlinux_raq-2800.gz and vmlinux_RAQ.gz pointing to
it, and that seems to work for everyone.

        Thanks for the reply.  I thought this might be the case.  I suspect
something weird is going on firmware wise.

        When this user tries to boot, the system reports back "Unknown
Compression Method".  A full log from the serial console is here:
<>.  I suspect the system, as
the colo-chain.elf is simply gzipped and named 'vmlinux.gz'.

        We also get the same error message when using the Debian netboot images
-- which is interesting to say the least.  I've looked around but
haven't seen any comments regarding Gentoo or Debian on a RaQ1.  Has
anyone tried installing a modern Linux distribution on these boxes?
| Stuart Longland -oOo- |
| Atomic Linux Project     -oOo- |
| - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - |
| I haven't lost my mind - it's backed up on a tape somewhere |

Attachment: signature.asc
Description: OpenPGP digital signature

<Prev in Thread] Current Thread [Next in Thread>