[Top] [All Lists]

Re: Error :Nomatch found in TLB ?????

To: "Srinivas JT." <>
Subject: Re: Error :Nomatch found in TLB ?????
From: Pete Popov <>
Date: Wed, 21 Jul 2004 09:53:19 -0700
In-reply-to: <>
Original-recipient: rfc822;
References: <>
User-agent: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.6) Gecko/20040113
Srinivas JT. wrote:

Dear All,
I am very new to this group.
I tried to load my .serc file into my Db1500 SDB. The steps that I followed are,

1) I wrote a filein C(Linux).
2) I generated an object file using gcc.
3) By using objcopy I converted my obj file into srec file.
4) Then I tried to download my srec file into Db1500 SDB in Yamon using tftp.

then I got error as,

Error: No match in TLB for mapped address  : Address = 0x00000000

Why I am getting this error ?. Is any error there in my procedure..?

Link your image to kseg0, not a virtual addresses like 0. The kernel, for example, is linked at kseg0 so the srec addresses are at 0x80100000. Since not tlbs are required for kseg0, yamon does not have problems loading into that region.


<Prev in Thread] Current Thread [Next in Thread>